LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW

IMG_20240425_160314_420.jpg

Good afternoon. I need to connect a YOKOGAWA AQ6370 spectrum analyzer to a computer via LabVIEW to control it remotely. I installed all the necessary drivers and software (driver for AQ6370, NI-VISA, driver for GP-IB), but the error still appears. What could be the problem? On the screenshot there is a link to a solution to the problem, I did everything from there, but it didn’t work. Perhaps a completely different program is needed, or is it a problem with the spectrum analyzer? LabVIEW version - 2016

0 Kudos
Message 1 of 20
(561 Views)

Hi Zariya,

 

the error says "the given reference is invalid". Which reference do you use?

Can you show a screenshot of NI-MAX with all available GPIB devices visible?

 

Btw. a thread title "Labview" is wrong in two ways: you should spell LabVIEW correctly and every thread in this board is about LabVIEW so you should use a more descriptive title!

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 2 of 20
(560 Views)

The VISA Session in the lowest part of the screen seems totally empty. While it may not be the control used in the VI to actually define which device to use (we can't say as you only attached a picture and pictures don't show even half of the important things in a LabVIEW VI), but if it is this can of course not work!

Rolf Kalbermatter
My Blog
0 Kudos
Message 3 of 20
(550 Views)

IMG_20240425_165456_530.jpg

 I use the driver link when I click on the Find Instrument Drivers button

0 Kudos
Message 4 of 20
(549 Views)

IMG_20240425_165939_035.jpg

 nothing can be changed here:(

0 Kudos
Message 5 of 20
(539 Views)

Then you need to go into MAX and make sure the device is recognized and visible there! Gert already asked you to show a screenshot of NI-MAX. For GPIB devices, as long as the device doesn't appear in there (unless you know the GPIB address and enter a generic GPIB address alias in the VISA control) you won't be able to talk to it from LabVIEW.

Rolf Kalbermatter
My Blog
0 Kudos
Message 6 of 20
(519 Views)

IMG_20240425_174048_093.jpg

IMG_20240425_174155_900.jpg

 Sorry, but I don't understand how to view this 😞

0 Kudos
Message 7 of 20
(488 Views)

Hi Zariya,

 

there only is the USB-GPIB converter visible in MAX (upper image), but no connected device.

As Rolf said: when there is no device visible in MAX then you cannot connect to it by selecting a VISA resource.

 

Is your device even connected to your computer?

Do you have some other software (from device vendor?) to check this connection?

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 8 of 20
(482 Views)


  1. Select the NI GPIB-HS "GPIB2" in the tree in the left pane
  2. Then Right Click on it and select "Search for Instruments" from the pop-up menu
  3. NI-MAX should then find your instrument is if is IEEE 488.2 compliant
  4. BTW: Did you also install the NI-488.2 package?

IMG_20240425_174155_900.jpg

 

If your instrument uses Ethernet and is VX-11 compliant (VXI or LXI) you can do basically the same thing by right clicking on "Network Devices" and selecting "Add Instrument" then follow the prompts. 

 

Also I have never used your instrument, but most instruments need to be manually setup to enable the remote interface.

Things like GPIB address, IP address, serial protocol, enable remote control, etc. will need to be set on the instruments itself before MI-MAX will find it.  

========================
=== Engineer Ambiguously ===
========================
Message 9 of 20
(456 Views)

Look at your very first picture.  The VISA session is not selected.  If you actually have NI-VISA and NI-488.1 (GPIB) installed, the address of your OSA should show up in the VISA session list.

 

If you have been playing around, trying to fix this, I suggest you restart your OSA and close LabVIEW completely.  VISA references are notorious for getting confused when they are not closed properly.

 

Of course, also ensure you are properly plugged in to the correct GPIB port.  Most of our 6370s have a main AND an aux.  Use the top one.

 

EDIT:  Just saw that Rolf already mentioned the empty VISA session control.  Check your connections and try restarting everything.  I use these OSAs every day and have never had any problems communicating with them.   🤔

LabVIEW Pro Dev & Measurement Studio Pro (VS Pro) 2019
0 Kudos
Message 10 of 20
(409 Views)