LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW executable will not run properly

Solved!
Go to solution

I made an application that uses 3 csv files, makes some operations with the data and writes the results in an xml file, it also sends some keyboard commands, to windows, to control a third party application I have on my computer.

The vi runs as expected, in LabVIEW, but when I try to run through a standalone exe or after installing it, I can only see the LV icon, on the right corner and a white toolbar.

Can someone please help me create a project and an exe, that doesn't have this problem anymore?

I made it with LV 2018, and Win 7.

I will leave a lower version LV VI, so that you can view the code.

I am able to create EXE just fine, with other applications, its just this one that's causing the issue.

Thanks.

0 Kudos
Message 1 of 3
(172 Views)

That is a large VI taking up dozens upon dozens of screen space.  I couldn't even run a block diagram cleanup on it.

 

Why so many sequence structures?

Why are there so many layers of case structures, event structures, loops, and sequence structures.

Why do you take a value from a single shift register and branch it to a dozen tunnels before sending them all into case or event structures?

 

You need to refactor this from the beginning.  Try flattening out the overall architecture so you don't have so many nested structures.  Combine related processes and make subVI's.  Right now it is so unreadable, no one who is not familiar with your code will be able to figure out what you are trying to do.

0 Kudos
Message 2 of 3
(156 Views)
Solution
Accepted by topic author Nando88

I fixed the proble I was having. The solution is to dele the absolute path to the user32.dll, just leaving the name of the file with the extension, that allows you to create an executable and an installer to distribute an application that uses a windows dll.

0 Kudos
Message 3 of 3
(116 Views)