LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW crashes on startup

Solved!
Go to solution

Hi!

I have installed LabVIEW 2016 (Professional Development System, German Version) and most of the Device Drivers.

The installation was successful, but LabVIEW crashes immediately if I try to start it.

This message appears:

Wir bitten um Verständnis für die Unannehmlichkeiten.

In LabVIEW 2016 trat ein Problem auf. Das Programm muss geschlossen werden. Um die Ursache des Problems zu finden, senden Sie bitte dieses Protokoll an National Instruments.

Ausnahme: Unknown (0xC06D007E) bei EIP=0x7582C54F

Version: 16.0 (32-bit)

 

I have tried to re-install it completely. This was successfull, too, but starting Labview is not possible.

A try to start it with windows-admin-rights also fails.

 

Does anyone have the same problem and a solution for it?

 

Thanks in advance,

Michael

 

 

 

 

0 Kudos
Message 1 of 8
(3,403 Views)

Michael,

 

do you have any parallel installation of LV?

Did you copy elements from older versions of LV (e.g. LabVIEW.ini) into your new installation?

What version of Windows are you using?

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 2 of 8
(3,394 Views)

Hi Norbert,

 

I'm using Windows7 64-Bit.

No, there isn't any parallel installation of LV. And for the re-install, I completely uninstalled it.

The clean-install was the only thing I did. This error appeared after the first start I have done, in order to check if LV is working.

0 Kudos
Message 3 of 8
(3,390 Views)

Do you use original NI install media? Is that an USB stick or DVD?

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 4 of 8
(3,387 Views)

It was the original DVD-set from NI.

I will check if the LV2016 will work on another computer tomorrow.

0 Kudos
Message 5 of 8
(3,366 Views)

Try going into the distributions folder of your media using the command prompt.  From there, run the command:  setup.exe /reinstall  (This is discussed in a KB about forced installations)

 

This often clears up issues with bad registry entries that might help get past what you're seeing.

 

Also, do you still have the media for the old version?  If you install that version, will it work or does it crash as well?

0 Kudos
Message 6 of 8
(3,358 Views)
Solution
Accepted by topic author EMDRX

Try launching MAX or other 32-bit NI applications. If any give an error saying the file api-ms-win-crt-runtime-l1-1-0.dll is missing, then the LabVIEW crash is likely the same problem even though the error message is different. See the following document for more information and a solution:

 

NI Application Is Not Launching because the File Api-Ms-Win-Crt-Runtime-l1-1-0.dll Is Missing

0 Kudos
Message 7 of 8
(3,196 Views)

jwp2000 I've tested your suggestion and as I see: It works!

 

To all: The solution is to install the Windows-Update KB299226 (Update for Universal C Runtime in Windows) as you can see above.

Thank you!

0 Kudos
Message 8 of 8
(3,173 Views)