Showing results for 
Search instead for 
Did you mean: 

LabVIEW can't find function inside dll

Hello, I seem to have a misterious problem, basically i created a dll (narma.dll) which is composed of three functions:


extern "C" __declspec(dllexport) initialize

extern "C" __declspec(dllexport) operate

extern "C" __declspec(dllexport) data_delayer


I have tried linking this dll on my computer, and everything runs smoothly, with no errors. I also built it using Debug x86 configuration in Visual Studio c++ 2015. It depends on 2 other dlls, blas and lapack x86 both of which i have set to my PATH system variable. VS also created a .lib file that is also on my PATH variable.


However, when I move all those files to another PC also running LabVIEW 8.5, it can not find the function inside the library. I have made all the steps above again, I appended those 2 dlls (blas and lapack) to PATH, tried rebuilding the dll using both Debug and Release x86 options, but nothing works, it finds the function name, but says later that the function was not found inside the dll.

I have no ideia what to do. I have Visual Studio C++ 2015 on both PCs, and the only required dll besides the one I made is the blas and lapack one which I have appended to the path variable. Is there anything I can do ?



0 Kudos
Message 1 of 1