Showing results for 
Search instead for 
Did you mean: 

LabVIEW and git

Go to solution

I've read all the different suggestions from all of you.

I was able to have LVCompare working in TortoiseGit with the following entry for .vi and .ctl files

"C:\Program Files (x86)\National Instruments\Shared\LabVIEW Compare\LVCompare.exe" %mine %base -lvpath "C:\Program Files (x86)\National Instruments\LabVIEW 2014\LabVIEW.exe"

As I wrote, I need -lvpath argument because on my PC I have multiple versions of LabVIEW.

So the Diff part seems solved.


I didn't find a way to have LVMerge working.

As a previous attempt I installed LabViewGitEnv and I think this configured somehow my git, since I get the following error while trying to merge


I don't have LabVIEW 2009 on my PC, but it's the default IDE in some of the scripts installed with LabViewGitEnv.

I modified the scripts so that they point to LabVIEW 2014, but nothing helps Smiley Sad

In claris non fit interpretatio

Using LV from 7
Using LW/CVI from 6.0
Message 11 of 14
Accepted by topic author vix

I was able to have LVMerge.exe working from TortoiseGit Smiley Happy

I openedthe file


and deleted all the entries added by LabViewGitEnv tool.

Then I set the merge tool of TortoiseGit as

"C:\Program Files (x86)\National Instruments\Shared\LabVIEW Merge\LVMerge.exe" "C:\Program Files (x86)\National Instruments\LabVIEW 2014\LabVIEW.exe" %base %theirs %mine %merged

both for .vi and .ctl files.


Not it seems working.

I think that LabViewGitEnv is an old tool and probably it needs some modifications to work as expected (at least on a Win7 SP1 64 bit PC with multiple versions of LabVIEW installed).

I'm going to do other tests in the next few days

In claris non fit interpretatio

Using LV from 7
Using LW/CVI from 6.0
Message 12 of 14

The Delacor article was incredibly helpful getting Tortoise Git setup for LabVIEW Compare and LabVIEW Merge tools.  I had done so successfully in the past with Tortoise SVN and it was harder to find the same resources for git.


Important:  The video "Git and LV Compare Setting up Git (with audio)" has the correct configuration string for both tools, however if you cut and paste directly from the video you end up with “ and ” around the path instead of the " symbols.  This didn't work for me until I substituted the " symbol in place and it worked fine after that.

Message 13 of 14

With smartgit configured in this way i'm also able to use diff (F4 show changes) so now i've tortoiseGit with diff and merge working. smartgit with diff working. maybe next step is configure smartgit witha working merge .


do not work. with this configuration smartgit search subvi's into the wrong folder.


and also i'm not able to delete this post. Smiley Very Happy

0 Kudos
Message 14 of 14