Showing results for 
Search instead for 
Did you mean: 

LabVIEW MyRIO toolkit 2020

Go to solution


just want to know if there is a LabVIEW MyRIO toolkit Version 2020 released?

Is there any workaround to use LabVIEW MyRIO toolkit with LabVIEW2020 if Version2020 hasn't been released?




0 Kudos
Message 1 of 15

I'm wondering the same thing.  Let me try some things and see if I can get this to work at all ...


Bob Schor

0 Kudos
Message 2 of 15

NI is being slow on releasing other drivers this year (RFSA, RFSG, VirtualBench).  Hopefully they will get it all caught up soon...

There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 3 of 15
Accepted by RavensFan

Good News -- I have a myRIO running perfectly well with LabVIEW 2020 and the myRIO Toolkit 2019.  Not only that, I'm running it in a VMWare Workstation VM, which I built out of "excessive caution" due to the 4-6 month struggle I had getting LabVIEW 2019 to "play well" with my current LabVIEW platform having LabVIEW 2016, 2017, and 2018 installed.


I'm going to outline, as best I can, the steps I undertook for this Installation.  If LabVIEW 2020 is the only version you have installed (or even if it is not, now that I think of it), you might want to consider a complete removal of all NI Software (safe ways to do this have been posted on the Web and on this Forum, including an earlier post I put up here) and installing from the beginning, especially if you are only running LabVIEW 2020 (because the Uninstall/Reinstall will be fairly fast).


Some of these steps were done two weeks ago, so I'm not 100% certain of all of the steps that I took.  However, I'll post Screen Shots from MAX that show the Software installed on this VM and on the myRIO Target, so you can compare with your results.


Installing LabVIEW "from scratch" safely:

  1. Download the LabVIEW 2020 NIPM Installer.  This installs NIPM 2020 on your machine, and you use NIPM to install everything else.
  2. Install LabVIEW 2020 32-bit.  You might be able to safely install LabVIEW 2020 64-bit, but I do not recommend it.  When you do this first Install, do not install any Modules or Toolkits, and do NOT install any Device Drivers.  Only install Add-Ons that you are sure you will use.  Reboot.
  3. Install LabVIEW Real-Time Module, NI PXI Platform Services, NI-DAQmx, and NI-VISA.  Again, be judicious with Add-Ons (I never check the .NET or C support, for example).  Do not install any FPGA toolkits.  Reboot.
  4. As far as I know, the myRIO Toolkit 2020 is not (yet) available.  However, the one "good thing" about NIPM is it does allow you, in many cases, to install older LabVIEW software "on top of" newer versions.  When NIPM is restarted, use its Search Features and find the myRIO Toolkit 2019.  Download and install this.  Reboot.
  5. This myRIO Toolkit needs the Vivado Compilation Tool 2017.2 (the current release of this tool is 2019, but I don't think it is compatible with the myRIO Toolkit 2019).  Download and install this.
  6. Your LabVIEW installation should now have a Software Configuration similar to this one (from my VM):



Now you need to plug in your myRIO and update its firmware.  In my somewhat limited experience (I've used LabVIEW RT over my entire LabVIEW involvement, but this is only the second distinct LabVIEW RT Project I've developed, the other being a PXI-based system), it has been the case that whenever the Host LabVIEW system underwent a significant upgrade (say, from LabVIEW 7.0, where I started, to LabVIEW 8x, 2010, 2012, 2014, 2016, and with the myRIO, 2014, 2015, 2016, 2018, 2019, and 2020), whenever the Host LabVIEW Version changed, I needed to update the Software (and occasionally the Firmware) on the remote Target (PXI or myRIO).  So that's the next step.


Start by plugging in the myRIO (via the USB connection).  In the Best of All Possible Worlds, you'll hear the distinctive "USB Waking Up" sound and will be greeted with the Configure myRIO.  I don't have all the steps as carefully written down, but here is what you are going to want to do:

  1. Open MAX.  You should see "Remote Systems".  Click it, "encourage" it to search for Remote Systems.  With luck, it will detect your myRIO.  If it doesn't, try the following steps --
  2. Right-click Remote Systems and click "Create New".  Choose the option "Remote System (not on the local subnet)".  When I tried this, it found the myRIO, even on WiFi.  You may need to know the USB "IP Address" -- it is
  3. If Step 2 doesn't work, try "Troubleshoot Remote System Discovery".  Again, you may need the USB IP Address (see Step 2).
  4. Once you get your myRIO "visible" in MAX, click on the Software Tab.  It may show some installed Software, but you are going to want to do a fresh installation.  When you click the Software heading, you should see Add/Remove Software appear on the right-hand pane.  I don't recall how it comes up, but you basically want to reinstall everything.  You might want to do an uninstall first, and then let MAX suggest what you install.
  5. This is what the myRIO on my system shows as its installed software:


So, does this work?  I've been developing some routines with a different myRIO, configured for LabVIEW 2019 and running on the machine that is Hosting this VM, where (only) LabVIEW 2019 is installed.  I wrote a very simple routine that does nothing more than establish 4 Network Streams between the Host PC and the Target myRIO, and as soon as they connect (after the Host "discovers" the myRIO's IP), they disconnect and end the program (the sign of Success is no Error Flags and the Host showing the correct IP for the myRIO.


I'm pleased (and relieved -- I ran it about 30 minutes ago for the first time!) to say it works!


So it is possible to run a myRIO using the LabVIEW 2019 myRIO Toolkit on a PC with LabVIEW 2020 (32-bit) as the only LabVIEW version installed.


Bob Schor


Message 4 of 15

Hi Bob,


Thanks for your post ! I followed your instructions but when it came to installing fresh software on the myrio using MAX to guide me to the optimal set, I was only given the option for the 19 driver versions. I installed those anyway, hoping that the 20 versions would somehow appear after installation.But alas it didnt occur. Just wondering if you used the custom installation options ? Also, did you need to do any bios upgrades ?





0 Kudos
Message 5 of 15

Hi Bob,


I did manage to do a custom install and get those components you show onto the my-rio. However, when i made a project I could find the myrio as a target.





0 Kudos
Message 6 of 15

Hello bob,


great you got it working. I followed your instructions, but i don’t got it working neither.

at the end i did’t get ni-myrio 2020 in max, but ni-myrio 2019 instead.

 What do you think went wrong. (I did also install labview 64, could that be the problem?. )

so i end up with a myrio with 2019 drivers, and a windows machine with both lv 2020 and 2019 drivers. So my computer did recognized the my rio, but in labview 2020 there is no way to find the myrio.


I will try again on a complete clean windows 10 computer. Do you have additional suggestions.

kind regards, Wim

0 Kudos
Message 7 of 15

Sadly, NIPM no longer provides a software install function now, which means your operation steps seems not gonna work now, bad news for everyone.

0 Kudos
Message 8 of 15

@WimK wrote:


 What do you think went wrong. (I did also install labview 64, could that be the problem?. )


     I'm pretty sure that you need LabVIEW 32-bit for the myRIO.  There's another Post on the Academic Forum where I also responded, but they are still having problems.  I'm going to do some more digging around, and will try to post what I find on both posts.


     For you, however, you need to do a "Safe Removal" of all NI Products, then reinstall LabVIEW 2020 32-bit.  Do a Web search for "Remove LabVIEW Completely", where you should find several discussions of how to do it safely.  Warning -- do not try doing "force" uninstalling by using a Registry tool -- this almost always prevents re-installing LabVIEW on that PC without first reinstalling Windows!  I've made this mistake twice (I'm a slow learner), and others have also had the same issue.


Bob Schor

0 Kudos
Message 9 of 15

I made what turns out to be a slightly premature statement saying that the myRIO works with LabVIEW 2020 (technically correct, but there's not yet a myRIO Software Toolkit, so you don't have the nice Express VIs that give you easy access to the myRIO hardware -- I'm going to find out more about this).


At the present time, the following seems to be the case:

  • LabVIEW 2019 (and 2019 SP1), 32-bit supports the myRIO and the myRIO Toolkit 2019.
  • LabVIEW FPGA Vivado Compillation Tool 2017.2, Version 2019, is the compiler installed with LabVIEW 2019.
  • LabVIEW 2020, 32-bit can run code compiled with LabVIEW 2019.
  • A myRIO built with these 2019 Tools will have a Firmware version of 7.0.0f0 and an Operating System of NI Linux Real-Time ARMv7-A 4.14.87-rt59-cg-7.0.0f0-xilinx-zynq-189.

If you install LabVIEW 2020, 32-bit, there is (as of 1 Jan 2021) no myRIO Toolkit 2020.  However, you can install myRIO Toolkit 19.5.  This does not have the Express VIs that make it simple for beginners to start using myRIO without having to delve into the arcane mysteries of LabVIEW FPGA.


In my case, I was developing a LabVIEW Real-Time Project that involved using Network Streams to communicate between a LabVIEW 2019 Host routine and code running on the myRIO.  This code ran perfectly well when opened in LabVIEW 2020, and I assumed all was OK.  As the other Project members were using LabVIEW 2019, I did no further testing at that time.


Recently, however, questions arose on the Forums about "Where is the myRIO Software Toolkit 2020?"  I naively suggested that the myRIO Toolkit 2019 would work fine (it seemed to work for me, right?).  However, holes started to appear, including the inability to use the simple "Personalities" that the myRIO Toolkit provide, giving you access to many Express VIs that provide access to the myRIO Hardware without having to write custom FPGA code.


Well, the Good News/Bad News is there is a myRIO Software update to Version 20.0, which updates the Firmware and Operating System of the myRIO (which might or might not render it incompatible with LabVIEW 2019 -- I haven't yet tested this!), and which might be difficult to "revert to previous version".  In addition, the "LabVIEW for myRIO" environment that the LabVIEW myRIO Toolkit 2019 provided (which gives you access to the myRIO Toolkit's Express VIs) is still not available.


For the courageous (or fool-hardy), here are some (incomplete) steps to take (I failed to write all the steps down, so some of this is from memory).  Here is the starting configuration of a myRIO, with LabVIEW 2019 installed (I'd updated to SP1, which I think explains the 19.5).  This is on a PC with both LabVIEW 2019 SP1 and LabVIEW 2020 installed, both installations configured to support myRIO (though there was no myRIO Toolkit for 2020). 



Notice the helpful "Add/Remove Software" that MAX shows.  I clicked it and got the following screen:



Needless to say, I choose NI myRIO 20.0 - May 2020.  After some time and several reboots of the myRIO, one of which updated the myRIO's Firmware (!) to 8.0.0f1, I ended up with this:


It also updated the myRIO's Operating System to 4.14.146-rt67-cg-8.0.0f1-xilinx-synq-139.  But still no myRIO Toolkit or Express VIs.


A warning, however -- I am pretty sure that it will be difficult to revert this myRIO to run the old Firmware and reinstall the old OS, and I have no idea if/how it will work with LabVIEW 2019 code.  I intend to test this -- fortunately, I have another myRIO that is happily unmodified ...


My advice?  If you are a beginner with myRIO, you really want the myRIO Toolkit.  The (Possibly) Good News is you might be able to install LabVIEW 2019 and the myRIO 2019 Toolkit "on top of" LabVIEW 2020 (with NIPM, LabVIEW became "better" about installing older versions after newer ones).  Indeed, it is possible that installing the LabVIEW 2019 Toolkit might "show up" in a LabVIEW 2020 myRIO system, but I haven't (yet) seen it.


Bob Schor


0 Kudos
Message 10 of 15