LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW IDE semi regularly hangs on exit

Highlighted

LabVIEW seems to be hanging semi regularly (once every 10-20 closes as a guess) when I close down all of my projects and return to the main screen and then close LabVIEW completely.

 

The process is still running with the application shown in the taskbar. As soon as I click on the icon to give focus to the main window, it pops up momentarily and then hides again. The taskbar close icon/menu action does nothing.

 

I'm running Windows 10 and LabVIEW 2016 (16.0). This also happened with 2015 SP1.

Anyone else had/have this happen?

Is there a way to capture logs for this? I've created a dump file, but it was over 700MB.

 

Thanks



Using LV2018 32 bit

Highly recommended open source screen capture software (useful for bug reports).

https://getsharex.com/
Message 1 of 7
(2,314 Views)
Highlighted

Hmmm.  I might have seen this, but I think I shrugged my shoulders and did a logoff/logon (or a Restart if I was really annoyed).  I don't recall seeing this on my Win7 machines, but I'll try to pay attention and, if I do see it, try to learn "a little more".

 

Bob Schor

0 Kudos
Message 2 of 7
(2,305 Views)
Highlighted

Thanks Bob.

Once I end the task/process from the Windows Task Manager, it works fine without a reboot/log off.



Using LV2018 32 bit

Highly recommended open source screen capture software (useful for bug reports).

https://getsharex.com/
Message 3 of 7
(2,239 Views)
Highlighted

I am still running 2015 on Windows 7 but I see the same thing. If I watch the memory allocated to LabVIEW, it will actually GROW before it eventually shuts down. It eventually shuts down but it take some time.

 

I have specualted, cleaning up temp files, deleting others, phone home...

 

So I have seen it and I have asked but never did get a good answer.

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
Message 4 of 7
(2,223 Views)
Highlighted

Thanks Ben. I must admit I've never left it longer than about a minute for it to self close. I'll see what happens if I leave it next time.



Using LV2018 32 bit

Highly recommended open source screen capture software (useful for bug reports).

https://getsharex.com/
0 Kudos
Message 5 of 7
(2,164 Views)
Highlighted

I've seen this exact thing, and when it happened to me it was because there were new opened VI references that weren't being closed.  I was using a toolkit that was opening VI references and not closing them, and the memory growth was so slow that you wouldn't really notice it, but on exit of the built EXE (or of LabVIEW in the development environment) I would see it hang for a very long time, and memory would slowly climb after issuing the exit.  I think it would some times take 20 minutes to finally exit.

 

I started disabling parts of the code and seeing when it would happen, and when it wouldn't.  I also needed to come up with repeatable cases where it would happen, like "If I run this test continually for 5 minutes then it takes about 2 minutes to close".  After a couple days of testing and disabling I found the issue with the toolkit.  I've since posted it publicly and told the author.

Message 6 of 7
(2,146 Views)
Highlighted

Good point about the toolkits, Hooovahh.

I'll have a look at these as well.

 

Thanks



Using LV2018 32 bit

Highly recommended open source screen capture software (useful for bug reports).

https://getsharex.com/
0 Kudos
Message 7 of 7
(2,081 Views)