Showing results for 
Search instead for 
Did you mean: 

LabVIEW: (Hex 0x627) Keyboard error


I am using a myrio 1900, and want to control a few things using the arrow keys.

I have made a VI for the same, but when deploying it to the myrio, I get this error:


LabVIEW:  (Hex 0x627) The function name for the lvinput.*:getKeyboardState:C node cannot be found in the library. To correct this error, right-click the Call Library Function Node and select Configure from the shortcut menu. Then choose the correct function name.


deploy error.PNG

I tried mass compiling it, but still the same error.

I have also attached the VI to detect key press.

Does anyone have ideas on how to fix this? Help will be appreciated.



0 Kudos
Message 1 of 4

I do not know a solution for this particular error, I guess you need to fix that call library node...?

However I have found another way to read inputs from a USB keyboard connected to the myRIO:

0 Kudos
Message 2 of 4


Thank you for your reply. Let me make it a bit more clear:

I have a rover that HAS to be controlled wirelessly.

When I use a shared variable, it works fine but that isn't user friendly because I have to run 2 VIs at once. And I definitely can't use a connected keyboard because thats connected via cable.

So, that makes things harder.


0 Kudos
Message 3 of 4

I'm a bit confused at what your ideal setup is here. If you want to control the myRIO wirelessly I would think that it would require you to run two applications.


I'm guessing the problem here is that the dll you are looking to use calls into some windows function at some point which is why it fails to deploy on a linux target. My first thoughts would be to do what Blokk suggested or something to the effect of acquiring user inputs from a host application and sending a TCP command to the myRIO.

Matt J | National Instruments | CLA
0 Kudos
Message 4 of 4