LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW FPGA: Xilinx error

Dear all,

 

Today I tried to recompile my FPGA with some slight changes compared to the previous version but nothing serious. Last time I compiled it was about 2 months ago and everything was fine. In between, I only updated the OS (Win7) but did no change whatsoever on LabVIEW. When trying to compile, first "xtclsh.exe" crashesl, then I get the following error message in the compilation status:

 

LabVIEW FPGA:  The compilation failed due to a Xilinx error.

Details:
ERROR:PersonalityModule:7 - Unable to open Xilinx data file for Vendor/Device
   Module "xbr".  Please make sure that it has been correctly installed before
   continuing. 
FATAL_ERROR:StaticFileParsers:StaticAcdRead.c:640:1.55 - ACD file .acd does not
   exists   For technical support on this issue, please visit
   http://www.xilinx.com/support.
FATAL_ERROR:StaticFileParsers:StaticAcdRead.c:658:1.55 - Unable to load file or
   override file "".   For technical support on this issue, please visit
   http://www.xilinx.com/support.
INTERNAL_ERROR:PersonalityModule:baspmspec.c:1751:1.79 - Could not load
   definition file <xbr.acd> 


Compilation Time
---------------------------
Date submitted: 27.09.2017 17:32
Date results were retrieved: 27.09.2017 17:33
Time waiting in queue: 00:15
Time compiling: 00:12
- Generate Xilinx IP: 00:00
- Estimate Resources - PlanAhead: 00:01
- Synthesize - XST: 00:04

 What I've tried so far is:

 

- Reboot the computer

- Upgrade Xilinx to its latest version via NI Update

- Try to compile the old vi instead of the new one

 

I'm honestly clueless and furthermore do not understand why it is not working anymore since I didn't change anything at all. Does anybody has an idea?

 

Best,

 

Martin

0 Kudos
Message 1 of 2
(1,165 Views)

Not sure if it was smart to upgrade xilinx. Have you tried a repair (of LabVIEW and\or FPGA module)?

0 Kudos
Message 2 of 2
(1,100 Views)