LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW FPGA 2015 - 7976 - Configure IP Page does nothing

Solved!
Go to solution
Highlighted

On some computers this works, on others it does not.  I have the following installed on both.  There may be something else I need and am missing.

 

I am trying to configure a FIR Compiler 7.2 on a 7976.  Any suggestions?

 

LabVIEW 2015 SP1f1 http://www.ni.com/download/labview-development-system-2015-sp1/5778/en/

LabVIEW FPGA 2015 SP1 (15.0.1) http://www.ni.com/download/labview-fpga-module-2015-sp1/5884/en/

LabVIEW 2015 FPGA Module Xilinx Tools Vivado 2014.4 http://www.ni.com/download/labview-fpga-module-2015/5492/en/

LabVIEW 2015 SP1 FPGA Module Xilinx Compilation Tool for Vivado 2014.4 f2 Patch http://www.ni.com/download/labview-fpga-module-2015-sp1/6407/en/

NI-FlexRIO 15.5 http://www.ni.com/download/ni-flexrio-15.5/5876/en/

 


Certified LabVIEW Architect, Certified Professional Instructor, LabVIEW FPGA expert
ALE Consultants
LabVIEW Programming (make LV more popular, read this)
0 Kudos
Message 1 of 5
(634 Views)

Attached is project and screenshot of what comes up

Here I click "Configure Xilinx IP"

And it gets stuck, no Next button.

 


Certified LabVIEW Architect, Certified Professional Instructor, LabVIEW FPGA expert
ALE Consultants
LabVIEW Programming (make LV more popular, read this)
0 Kudos
Message 2 of 5
(609 Views)

If nothing happens, then something may be running in the background - i.e. a zombie process, and you will probably have to clear out some files in the ip temp directory

 

  1. Exit LabVIEW, any instances of Vivado, and any of the Vivado tools (xelab.exe, xsim...etc) make sure there are no zombie processes of either as well by checking with Windows Task Manager.
  2. In the project directory, remove all files that were generated by any previous run on the Reconfigure IP Wizard.  On my computer, I see the following (after configuring this ip):
    1. xsim.dir/FIR_Compiler_F9FDA73D9036441EA87FFB505B7105B7
    2. FPGA-FIR-7.2-7976
  3. You may also want to clear out the "C:\NIFPGA\iptemp" directory. (Not required because a unique directory is used for all new ip)

If it still does not work, reboot your computer after cleaning up the temporary files.

0 Kudos
Message 3 of 5
(589 Views)
Solution
Accepted by topic author Terry_ALE

Xilinx IPs configuration doesn't work on Windows 10 - might be the same issue as here: https://forums.ni.com/t5/LabVIEW/LabVIEW-2015-Windows-10-Configure-Xilinx-IP-not-working/m-p/3668520...

0 Kudos
Message 4 of 5
(580 Views)
Solution
Accepted by topic author Terry_ALE
0 Kudos
Message 5 of 5
(578 Views)