LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

LabVIEW 8.6.1 Installation Builder Crashes Windows 7

Hello, my very helpful friends.  I have what I think to be a rather complicated issue and for which I've run out of ideas.  Recently, I had to go through the dreaded enterprise wide Windows 7 upgrade.  Upon completing that slog, I reinstalled LabVIEW 8.6.1 onto my machine by going to the distributions folder and installing each piece one at a time.  After completing this process, I opened a pre-existing project (stored on a separate server) which had some pending changes in a couple VIs which needed to be incorporated into the executable and installation builds.  The executable build worked without a hitch, but when I attempt to build the installation, I get most of the way through the build, but then it crashes Windows 7 via the blue screen once it gets to this point in the build:

Picture1.png

 

This is at the part where the progress bar stops proceeding for a minute or so.  I've tried deleting the installation and executable builds from the pre-existing project and recreating them, but that didn't work.  I've also tried completely reconstructing the project from scratch to no benefit either.  I've been able to succesffuly build both executables and installers in other projects since upgrading to Windows 7 so it seems particular to what's going on in this project.  The only other bit of information I can think of which might be useful is that every now and then, building the installer only crashes LabVIEW and not full Windows 7.

 

Any ideas or suggestions are appreciated.  Thanks in advance!

 

Andrew

0 Kudos
Message 1 of 8
(1,023 Views)

Have you tried copying to a different Win7 machine to see if it is a repeatable crash on other machines?

http://www.medicollector.com
0 Kudos
Message 2 of 8
(1,020 Views)

Oh ...

 

NI does not officially support LV 8.6.1 on Win7:

 

http://www.ni.com/labview/os-support/

 

That is probably the cause.

http://www.medicollector.com
0 Kudos
Message 3 of 8
(1,018 Views)

Yeah, I knew compatibility may be an issue, but I recall reading some messages which indicated people have been successful mating 8.6.1 and Windows 7 so I was hopeful some would chime in.

 

I have an upgrade to LabVIEW navigating the corporate bureaucracy, but that's still pending so I'm trying to make this work in the interim.  Thanks for the input.

0 Kudos
Message 4 of 8
(1,012 Views)

Haven't tried that as I'm one of the early adopters in my group and we only have the single license approved for my machine.

0 Kudos
Message 5 of 8
(1,010 Views)

I never tried using this, but one of the options you could consider...

 

http://windows.microsoft.com/en-us/windows7/install-and-use-windows-xp-mode-in-windows-7

TailOfGon
Certified LabVIEW Architect 2013
0 Kudos
Message 6 of 8
(1,006 Views)

Trying.  Will update later today with results.

0 Kudos
Message 7 of 8
(984 Views)

Using the Windows XP Compatibility Mode works...sort of.  The XP emulator adds a layer to path names in .dll calls which had to be updated and I spent 3/4 of the day confused, trying to get it right.  Still, I can build .exe and installers again.  Thanks!

0 Kudos
Message 8 of 8
(965 Views)