Showing results for 
Search instead for 
Did you mean: 

LabVIEW 8.5 app crashes in WinXP

Go to solution

Our customer is trying to start our legacy LV 8.5 application and XP says it "has encountered a problem and needs to close."


Clicking for more data shows:

ModName: lvs3a.tmp   ModVer:   Offset 0001012


Clicking for exception info shows:

Code: 0xC0000005   Flags: 0x00000000   Address: 0x00000000076E1012


I googled lvs3a.tmp and found nothing there nor here in this forum. I thought it might be a LabVIEW thing given the first two letters in the module name. Does this look familiar to anyone here?


FYI: many of our customers run this app on XP successfully, and so did this customer last week.

0 Kudos
Message 1 of 7

Searched here some more and saw that lvs*.tmp files are DLLs used by LV to run CINs. Is that right?


So, if that CIN DLL is crashing, might it mean that the application EXE file is corrupt? Because the CIN code is embedded in the EXE, right?


0 Kudos
Message 2 of 7

@ClausB wrote:


FYI: many of our customers run this app on XP successfully, and so did this customer last week.

So, what did they change since last week?

0 Kudos
Message 3 of 7

Of course, that's the first question I asked. Of course, they said nothing changed.


They sent me the PC and I ran a RAM test which found no errors. I ran CHKDSK which cleaned up some unused index entries and security descriptors. The app still crashed in lvs*.tmp. A virus scan turned up nothing (they never had it connected to a LAN nor the internet, and they claim to have never plugged in a flash drive).


I reinstalled the app, its DLLs, and LV8.5 RTE. Still crashes the same way.


Any ideas, short of reinstalling XP?

0 Kudos
Message 4 of 7

I say install a newer operating system that hasn't been out of support for 6+ years and work with a newer version of LabVIEW that isn't 13 years old.

0 Kudos
Message 5 of 7
Accepted by ClausB

It! It!


Turns out a folder with config files was missing. Restored it and no crash! Weird symptom for that cause though.


0 Kudos
Message 6 of 7

I know this doesn't help much, but an error due to missing config files should definitely be an expected error and be handled in an appropriate manner like letting the user know the files are missing!


So, yes "Stupid IT" - but also... well, you know.

(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 7 of 7