Showing results for 
Search instead for 
Did you mean: 

LabVIEW 8.2 can't work with DAQmx program written using LabVIEW8.0 ?

My old LabVIEW program is using the DAQmx sub-vis  from folder: C:\Program Files\National Instruments\LabVIEW 8.0\vi.lib\DAQmx
e.g. C:\Program Files\National Instruments\LabVIEW 8.0\vi.lib\DAQmx\create\channels.llb\DAQmx Create Channel (AI-Voltage-Basic).vi
After I installed LabVIEW 8.2 and (~600MB), there isn't a folder called DAQmx in folder:
C:\Program Files\National Instruments\LabVIEW 8.2\vi.lib\
When I load my old program, it need I specify the location of, e.g. DAQmx Create Channel (AI-Voltage-Basic).vi,
I copied DAQmx folder from \LabVIEW 8.0\vi.lib\ to \LabVIEW 8.2\vi.lib\
After I copied the DAQmx folder, right click on "block diagram" under "measurement I/O" the folder "NI-DAQmx" comes out and I can pick all the vis inside "NI-DAQmx"
However, all the vis are not executable.
My old program find all the vis needed to load; however, the vis are not executable, e.g. DAQmx Create Channel (AI-Voltage-Basic).vi, please see the attachment.
Anyone know how to solve this?  Thanks.
------- LabVIEW 2009, So Easy, Even a Therapist Can Do It -------
0 Kudos
Message 1 of 4
You should make sure that in the installer options of DAQmx the support VI's for LV 8.2 are installed.

Free Code Capture Tool! Version 2.1.3 with comments, web-upload, back-save and snippets!
Nederlandse LabVIEW user groep
My LabVIEW Ideas

LabVIEW, programming like it should be!
0 Kudos
Message 2 of 4
Thanks.  I select all the options (except Lab-windows and VC++) when installing DAQmx 8.3.1.  I did a Repair also:
Control Panel -> Add or remove programs -> National Instrument Software -> NI-DAQmx 8.3.1 -> Repair , after the 10 minutes repair, the select Distribution comes out.  I select NI LabVIEW 8.2 and insert my 8.2 CD.
It still not working. 
Finally, I copied the DAQmx folder from another 8.2 machine, it worked!!  I still don't know why I don't have DAQmx folder after 8.3.1 and 8.2 were installed in that machine.
------- LabVIEW 2009, So Easy, Even a Therapist Can Do It -------
0 Kudos
Message 3 of 4

I am glad you have it working now.  If you do have further trouble using DAQmx in LabVIEW 8.2 please let us know.  I would recommend uninstalling and then reinstalling DAQmx 8.3.1.  It sounds like you had DAQmx working with 8.0, but for some reason the install of the new DAQmx drivers you made did not install them on LabVIEW 8.2.  Uninstalling the DAQmx drivers, and then reinstalling them should clear up this problem.  Please let us know if you are still having difficulty.

Have a great day,

Michael D
Applications Engineer
National Instruments
0 Kudos
Message 4 of 4