LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW 5 (!) Problems Building Executable from LLB

Looking for advice from other oldtimers on the list.  I'm working for a client to make mods to a very old test stand that uses LabVIEW 5.0.  All the files are located in an LLB.  When I run the files from the LLB, everything works well, but when I use Application Builder to make an executable, I get an error saying that a subVI is not executable.  Any ideas on how I can troubleshoot this?

Thanks very much.

Forbes Black
Lapsed CLAD, LV 2020 & 2018
0 Kudos
Message 1 of 4
(1,759 Views)

Since it was in a llb it was no problem to copy it to another llb,.then proceed to building exe. or try to make a new project  and start it out by copying/saving the vi's to a directory then include to your new project.



Thank you & Best regards
syrpimp

=======================================================
“You must continue to gain expertise, but avoid thinking like an expert." -Denis Waitley
0 Kudos
Message 2 of 4
(1,732 Views)

It is in LabVIEW 5, so applications are not built from projects.  I think that is where my confusion starts...

 

Thanks for the reply.

Forbes Black
Lapsed CLAD, LV 2020 & 2018
0 Kudos
Message 3 of 4
(1,731 Views)

You can then (in "Source File Settings") put all sub VI's in the new llb. I'm not sure where all the support vi's go. Probably in the main exe, but if they end up in the llb, you're done!



Thank you & Best regards
syrpimp

=======================================================
“You must continue to gain expertise, but avoid thinking like an expert." -Denis Waitley
0 Kudos
Message 4 of 4
(1,723 Views)