LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

LabVIEW 2015 not installing, autorun.exe 'encountered an improper argument'

Solved!
Go to solution
Highlighted

Hi,

I recently got a new laptop and tried to install labVIEW on it. It started installing, but the system lost power halfway through and shut down. I deleted the National Instruments folder in Program Files (x86) and retried, but when I run autorun.exe it says 'encountered an improper argument' with a red 'X'. So I tried running setup.exe, and it starts, but bypasses LabVIEW and goes on to the real-time module, where it says 'LabVIEW 2015 must be installed before installing the real-time module. Any help would be appreciated.

Thanks

0 Kudos
Message 1 of 14
(1,715 Views)

Is it a problem of improper uninstallation of NI products?

This link seems to be older but might help:

http://forums.ni.com/t5/LabWindows-CVI/Encountered-an-improper-argument/td-p/2383778

0 Kudos
Message 2 of 14
(1,710 Views)

 Hi LVKrAkEn,

I already went through that thread and it didn't seem of much use to me, even though they have the same problem. I can't do much in the registry either.

0 Kudos
Message 3 of 14
(1,701 Views)

Could you please tell us whether you can see the National Instruments Software in Programs and Features?

0 Kudos
Message 4 of 14
(1,679 Views)

If NI Software is shown in Programs and Features, you need to either Remove All or Repair All.  Software cannot simply be "deleted" from your hard drive -- once installation begins, it starts adding things into your system itself (the mysterious "Registry"), and this needs to be "undone" before you can proceed.  An "Uninstall" (or "Remove All") is the simplest and safest way to do this.

 

Bob Schor

0 Kudos
Message 5 of 14
(1,672 Views)

I had mentioned in the post that I deleted it (yes, shift+delete) from program files. I did not uninstall as it had been aborted as the laptop shut down.

0 Kudos
Message 6 of 14
(1,658 Views)

And did you remove the National Instruments elements from the registry?

 

(remember to backup registry settings before making any changes!)

 

HKEY_CURRENT_USER\Software\National Instruments
HKEY_LOCAL_MACHINE\Software\National Instruments

0 Kudos
Message 7 of 14
(1,653 Views)

Was I supposed to? And how do I create backup for it?

0 Kudos
Message 8 of 14
(1,640 Views)

Hi,

here is some information on how make registry backups:

https://support.microsoft.com/en-us/kb/322756

 

If you remove the ones I mentioned above, you remove all the NI registry changes so it can help. You can do it just by running regedit.exe

Here is some general information on how to modify registry entries: http://www.makeuseof.com/tag/what-is-the-windows-registry-editor-and-how-do-i-use-it-makeuseof-expla...

 

This is not an officially supported way of solving issues with LabVIEW installation, but you can give it a try.

0 Kudos
Message 9 of 14
(1,638 Views)

Hi stockson, 

Tried that out but no luck, even after rebooting.

0 Kudos
Message 10 of 14
(1,630 Views)