LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW 2009 crash a lot

I agree its poor and far worse than the V8.0 I have standardised on for a couple of years and V7.1 before that. It crashes at least three times a day. Typically, as the previous corespondent said, when you try to save from the program editor window. It can take MS Windows several minutes to shut the crashed program down. Auto recover has worked on all but one occasion when I had to revert to an earlier backup. Im not aware I'm doing anything untypical in my code, but am running the 32 bit LV9 on a 64 bit Windows 7 PC across two monitors.

 

I don't plan to upgrade my commercaly important programs untill I see a more stable platform.Smiley Mad

0 Kudos
Message 11 of 24
(989 Views)

I have noticed that LabView is crashing far more than it used to. Autorecover has sometimes worked but not always. My LabView crashes seem to occur when doing something totally innocuous like moving a case structure wiring a component up, nothing fancy.

 

Simon

0 Kudos
Message 12 of 24
(962 Views)

I have been using LV2009 SP1 to modify may TestStand 4.1.1 LabVIEW operator interface. Twice today, not only did it crash - but when it tries to recover the file it crashes again. I have no choice but to go back to yesterday's version and do all my work again.

 

Any fixes out there for crashes on recovery from an orginal crash?

 

Stick to LV7.1 if you can.

Thank you for letting me vent...
0 Kudos
Message 13 of 24
(821 Views)

Try openning your LabVIEW project first before the TestStand.  I have found that sometimes the LabVIEW and TestStand are looking for files and / or resolving conflicts.  Some of these require user interaction that seems not to pop-up so it hangs.  We have a system with TestStand 4.2.1 and LabVIEW2009 that uses a large LabVIEW project written object oriented style.  This the third computer to use this same software and first to convert it from LabVIEW8.6 and TestStand4, has the same problem, Opening the TestStand sequence seems to hang trying to load the LabVIEW.  Closing TestStand and LabVIEW then opening the project first and clicking ignore on the found stuff in a new location warning message allows the project to successfully load.  Once the project is loaded then the TestStand sequence will run correctly.  I don't have a good workaround to automate the opening from TestStand, but I think if the LabVIEW project is saved such that there is no found stuff in new location message, it ought to work.

0 Kudos
Message 14 of 24
(809 Views)

I don't think we are talking about the same thing. I'm not talking about loading a sequence that uses LabVIEW 2009 vi's. I'm using LV2009 to modify the Operator Interface that controls TS4.1.1.

 

When I try and open the vi from LV2009 the system crashes. I have no oportunity to resolve broken links to other vis.

 

 

 

0 Kudos
Message 15 of 24
(793 Views)

There's more than one way to open a VI.  Try the File Menu Open, try drag-n-drop to a diagram of a blank VI, use the menu from the diagram of a blank VI to place it on the diagram (this should stop it from running when opened), or try open dynamically.  The open dynamically method might benefit from setting some properties before opeing the panel.  There is a property that is called Edit Mode on Open that sounds like a good one to try.  Or try another version of LabVIEW.  Try renaming it or copying it to another folder.  If it is a standard NI software GUI for controlling TestStand, you could download a new one.

0 Kudos
Message 16 of 24
(781 Views)

Great tips but no success...

 

- place on diagram -> crashes

- open dynamically -> there is already a vi to launch it this way, and I added "edit mode on open" as a properly but it still crashes

- renaming -> crashes

- LV 2010 -> crashes

 

Some of the things you mentioned I can't do, since the Vi is in a library file, i.e.. Drag and drop.

 

I can go back and start again with an earlier version, but this has happened twice already, I can't keep doing this. I will be phoning NI.

 

Thanks

0 Kudos
Message 17 of 24
(763 Views)

It may help to mass compile your VIs.  You can do this from within LabVIEW and choosing Tools->Advanced->Mass Comile...  This should help recompile VIs that may have been corrupted.

National Instruments
Applications Engineer
0 Kudos
Message 18 of 24
(746 Views)

I tried mass compiling the library the vi was in, and LV2009 crashed.

 

I've opened a service request number on this one, and have just sent the vi's to NI.

 

Thanks

0 Kudos
Message 19 of 24
(737 Views)

I think i've liked the 8.6 release the best so far. For the features and stability in the version. Except for mass compile in fpga...i think it has some strange bug on that.

 

2009 was buggy for me. Even the update for it was buggy and would crash at least once a day.

 

Now im on 2010 with the latest updates and i cant get 5 minutes into without a crash. Not sure if its the VLC activex im trying to use or just 2010. I had to completly reboot my pc earlier to get it to start again. Labview would just not open up. I'm almost wondering if i should completly remove all labview versions and load 2010 from scratch. Or just load 8.6 since it seems to run better.

 

Another day of this and i think im going to call NI.

 

-Corey

- A minute saved is a Minute earned!
0 Kudos
Message 20 of 24
(656 Views)