Showing results for 
Search instead for 
Did you mean: 

LV2013 hangs on Resolve Load Conflict Dialog



Thanks for the tips and updates on this.


I tried mass compiling as was suggested but I was again able to reproduce the issue as I have described it in the first post. (Report ID: f6783551-a533-4d1e-982b-845a9fabea9f )


Then I tried uninstalling the VSI TSVN toolkit and I couldn't get it to crash again.


Next I reinstalled the toolkit and mass compiled as suggested => no crash. Hope it stays like that also 🙂


Thanks again and keep up the good work guys!



0 Kudos
Message 21 of 39

FYI: I've been seeing this randomly for some time. I do have the Tortoise SVN toolkit installed but believe I have seen this before adding it.  When it occurs, the dialog continues to increment the "Loaded" count but otherwise things are just hanging

0 Kudos
Message 22 of 39


Whoops they did it again


I'll try a MC There

"Should be" isn't "Is" -Jay
0 Kudos
Message 23 of 39

Steps to reproduce:

  • Have a project open
  • Realize "Hey I need a pausable resetable timer for this vi" (I Just linked to one on the community this week so go here)
  • I know I'll need the enum type def so download that first and save as (sub copy for original)
  • Download write up the report for Jeff P

"Should be" isn't "Is" -Jay
0 Kudos
Message 24 of 39

Hello everyone,


An update on this issue - we have been working with Viewpoint and version 1.8 of the TSVN toolkit will be released shortly through VIPM to fix this. If you still experience this issue after installing 1.8, please post back to this thread.


Thanks for your help and happy new year!


Jeff Peacock 


Product Support Engineer | LabVIEW R&D | National Instruments 

Message 25 of 39

Further update:


2 new versions of TSVN Toolkit are available on the LabVIEW Tools Network in VI Package manager and both SHOULD resolve this issue. Version resolves the issue and supports TSVN 1.7.x only. also resolves the issue and supports TSVN 1.8.x only (1.8 was previously unsupported).  You can download both from VIPM or here and then choose the appropriate version of the package in VIPM (see below)




Message 26 of 39

I have VSI TSVN Toolkit v1.8.0.1 and saw the dialog pop up and same problem - ie. the labview dialog showing the conflicts pops up just prior and the two dialogs "lock each other out".  Only difference seems that the is not modal to the project window so I was able to close the project before force closing the dialog with task manager.  I left it overnight prior to doing so.

0 Kudos
Message 27 of 39

I found this thread today. I checked and had the 1.8.0 version of the toolkit. Updating it now.  Hopefully this problem goes away, if not I will just leave the toolkit uninstalled for now.

CLD LabVIEW 7.1 to 2016
0 Kudos
Message 28 of 39

nope. still crashes.


I have a project folder where I was re-organizing some files in preparation for building a pacakge (using package manager). In the process one example/test vi needs to be re-linked to the lvclass and I get the "Resolve Load Conflict" dialogue behind the "" dialogue which offers "stop..." as the only valid choice and it of course does not work.


I'll be removing the toolkit for now.


Toolkit was the 1.8....1 version (latest)

I have TortoiseSVN version ::

TortoiseSVN 1.8.4, Build 24972 - 64 Bit , 2013/11/24 11:15:39
Subversion 1.8.5, -release


2013 fully updated, and less than 2 week old clean install of windows/labview/everything.

CLD LabVIEW 7.1 to 2016
0 Kudos
Message 29 of 39

Just as an update, I have been actively working to solve this problem, and I think I have a solution, but it has required refactoring a large amount of code. I hope to have a new version of the toolkit out in the next week or so that will hopefully solve this issue once and for all. Thanks for your patience.


In the mean time, I would be happy to answer any other questions about the TSVN Toolkit.




Message 30 of 39