LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LV2010 DSC alarm troubles

Highlighted

I recently upgraded from LV2009/DSC2009 to LV2010/DSC2010. My development system code works fine in LV and also built into an exe. But on the "users" station my .exe doesn't work any more. Everything seems fine except for alarms. They are constantly in alarm. All 90 of them. They are boolean values that I have converted from INT values from the PLC. The outputs from the PLC via RSLinx OPC server are all 0's and appear OK. What is really strange (and probably significant) is that the value from "DSC_Read Alarms.vi" is 64. Smiley Surprised When it was working it was a value of 1 when in alarm and 0 when not in alarm.

PaulG.

LabVIEW versions 5.0 - 2020

“All programmers are optimists”
― Frederick P. Brooks Jr.
0 Kudos
Message 1 of 3
(832 Views)
Highlighted

Update: re-building an application in LV2009 still fails in the operator console and everything is still fine in my development system. The app worked in the operator's console when it was only running a 2009 exe with DSC 2009. Still working on this guys. Any ideas of where to look? Thanks in advance.

PaulG.

LabVIEW versions 5.0 - 2020

“All programmers are optimists”
― Frederick P. Brooks Jr.
0 Kudos
Message 2 of 3
(800 Views)
Highlighted

Another one of those "LabVIEW can fix itself if you give it enough time" issues. I was playing around with the DSM 2009 and 2010 and RsLinx Classic on the target machine and it started working. I really didn't "do" anything except look at tag values from the PLC. Strange. Disturbing. Smiley Indifferent

PaulG.

LabVIEW versions 5.0 - 2020

“All programmers are optimists”
― Frederick P. Brooks Jr.
0 Kudos
Message 3 of 3
(781 Views)