LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LV2010 Build Application: Error 1498 occurred at Get LV Class Default Value.vi

Solved!
Go to solution
Highlighted

I am trying to create an application (exe) file with LabVIEW 2010 Professional Development System SP1 (32 bit). The operating system is Windows 7 Professional (64-bit). Unfortunately I am getting this error, when I click on 'Build Specifications/New/Application (EXE):

 

error screen shot

 

 

Here is the complete error message

 

Possible reason(s):

LabVIEW:  Library has errors. Fix the errors before attempting this operation.


Complete call chain:
     Get LV Class Default Value.vi
     AB_UI_Initialize_Framework.vi
     AB_UI_FRAMEWORK.vi
     AB_CreateNewWizard_Invoke_CORE.vi

     EBUIP_CreateNewWizard_Invoke.vi
     EBUIP_CreateNewWizard_Invoke.vi.ProxyCaller

 

LabVIEW attempted to load the class at this path:
C:\Program Files (x86)\National Instruments\LabVIEW 2010\vi.lib\AppBuilder\AB_Classes\Build\UI\AB_UI_Frmwk_Build.lvclass

 

The file is definitely available.

 

Well, here is also the code 🙂

test code

 

Do you know what is going on? I guess it cannot be so complicated to build an executable. Am I doing something wrong?

 

Thanks, Nick

 

0 Kudos
Message 1 of 15
(2,359 Views)

Hi Nick

 

Is the given error specific to this particular VI or does it occur for all VI's ?

0 Kudos
Message 2 of 15
(2,354 Views)

The VI doesn’t matter. I was working on a VI for serial port communication. I needed an executable version of it and tried to compile it. The Application Builder shows then exactly the same error. Then I decided to try something very simple, just to make sure it works. Unfortunately this doesn’t work also.

0 Kudos
Message 3 of 15
(2,343 Views)

Chembo,

 

Im sorry you have encountered this error. Error 1498 and the behavior you are experiencing may require a repair of LabVIEW. This appears sometimes in 2010 and was on the scheduled fixes for 2010SP1. You can upgrade here:

 

http://digital.ni.com/src.nsf/home?OpenForm

 

🙂 I hope that gets you going

Sam S
Applications Engineer
National Instruments
0 Kudos
Message 4 of 15
(2,336 Views)

Hi Sam,

 

Thanks for the link. I can find Service Pack 1 on this location, but I have already SP1 installed on my PC. Actually, the LabVIEW installation DVD came already with SP1. Is the download revision newer?

 

Here is the screen shot of my LabVIEW:

LabVIEW SP1

0 Kudos
Message 5 of 15
(2,329 Views)

Depending on when you installed LabVIEW 2010SP1 the one on the website may be a newer build 🙂

Sam S
Applications Engineer
National Instruments
0 Kudos
Message 6 of 15
(2,327 Views)

Unfortunatelly the SP1 download didn't help. I started the installation, but it finished pretty fast and I am getting exactly the same error.

Any other suggestions?

 

Thanks, Nick

0 Kudos
Message 7 of 15
(2,318 Views)
Solution
Accepted by topic author chembo

Hmmm you could try doing a repair of LabVIEW. Go to start > control panel > add and remove programs > National Instruments > modify (repair) LabVIEW. This will go through and make sure it has the correct paths to the application builder. Let me know if that works 🙂

Sam S
Applications Engineer
National Instruments
Message 8 of 15
(2,311 Views)

I cannot find 'add and remove programs'. Just kidding; it is now 'Programs and Features' in Windows 7. I didn't know this also.

 

I started the repair for the Service Pack 1 (SP1) and it works Smiley Happy

 

Thanks for your help,

Nick

 

0 Kudos
Message 9 of 15
(2,299 Views)

hahah wll played! 

 

Good Im glad your up and running! 🙂

Sam S
Applications Engineer
National Instruments
0 Kudos
Message 10 of 15
(2,295 Views)