LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LV RunTime: "vi is broken or one of it's subVIS can't be located"

I can open my vi in the LV development environment but not in the LV RT. In the RT it states the vi is broken. Probably because in the DE the search directories are added.

0 Kudos
Message 1 of 27
(1,056 Views)

Hey JoVMo,

It could be that you are using VIs that ship with LabVIEW DE and not RT. Can you list the vi that it is looking for?

If the SubVI in question is your own creation, have you looked at your source distribution?

 

Please attach your VI so we could help you better,
Regards, 

Prashanth N
National Instruments
0 Kudos
Message 2 of 27
(1,050 Views)

The only dependency I see is the FP winbounds an FP open. How come the RT doesn't know the locations of the subVIS?

0 Kudos
Message 3 of 27
(1,046 Views)

Hi JoVMo,

I know this might be redundant, but could you put a screenshot of the dialog you get? I'm trying to check which VI in specific is causing your VI to break.

Also, I could not reproduce it here because your VI is missing its own dependancies, Agco-Z9.lvlib.

 

Regards,

 

Prashanth N
National Instruments
0 Kudos
Message 4 of 27
(1,039 Views)

The VI is running from a sequence in a TST RT engine. Strange why it's referring to the .llb. Because I save it standalone?

0 Kudos
Message 5 of 27
(1,037 Views)

JoVMo,

Its not a .llb, its a .lvlib. I'm saying it to just make sure we're on the same terms when we say that the library is missing, its the "user-defined library" and not a LabVIEW file that's missing.


As far as the VI you sent me, I used File >> Disconnect from library to make sure it is runnable, and ran it from Teststand. It runs without any issue. That is as expected since your VI contains almost nothing except the two property nodes that you mentioned, and those two do not have any specific dependancy.

Does this answer your questions?

Regards,

Prashanth N
National Instruments
0 Kudos
Message 6 of 27
(1,031 Views)

Please some more info on .lvlib and .llb? What's the difference? Tnx!

0 Kudos
Message 7 of 27
(1,023 Views)

When we talk about llb's we are almost always referring to the libraries that ship with LabVIEW, and the vi.lib VIs, and so on. An lvlib is a user created project library file to which he can add VIs, type defs, etc. 


You can find more information here:

http://zone.ni.com/reference/en-XX/help/371361H-01/lvconcepts/project_libraries/

 

Have a great day!

Prashanth N
National Instruments
0 Kudos
Message 8 of 27
(1,012 Views)

 

 

Prashanth N
National Instruments
0 Kudos
Message 9 of 27
(989 Views)

JoVMo,

 

Is the problem solved?

 

Regards,

Prashanth N
National Instruments
0 Kudos
Message 10 of 27
(988 Views)