LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LV RunTime: "vi is broken or one of it's subVIS can't be located"

I get another fault. "CurrentLV to early". I can open the file in LV 2010. The RT is set to LV 2010. ?? The RT installer is made with the LV 2011 discs.

0 Kudos
Message 11 of 27
(244 Views)

That is expected. Your RTE will find it hard to understand LV 2011 because, it was created much before it 🙂

Please use File >> Save to previous to make sure your files are saved to 2010.

Prashanth N
National Instruments
0 Kudos
Message 12 of 27
(235 Views)

I saved my files for LV2010. Now I can run it on a system with TST and LV development environment installed. But when I run it on another system with only the RT I get again the error of a broken vi.

 

I already disconnect from the library.

0 Kudos
Message 13 of 27
(233 Views)

Hey,

 

Its really hard to understand and debug from the information. Could you please provide versions of LV, RTE, TST you are using on these machines?

If your RTE is same on your TST machine and the new machine, it should work without error.

It could also be, that the "Save for Previous" resulted in a broken VI which you tried to call using RTE.

I'll give you this generic solution:

Try to first open the VI in LV dev environment, and see if everthing is ok, and then copy this on to your machine with RTE. Remember that the versions of these two must match for you to make any meaningful conclusion!

 

Regards,

Prashanth N
National Instruments
0 Kudos
Message 14 of 27
(231 Views)

Pachi,

 

I'm working on a network drive. So if I edit a version with the development system, then the RT must load that same version.

0 Kudos
Message 15 of 27
(228 Views)

I understand that, JoVMo, but I want to make sure that your dev system and RT are the same release version. I'm assuming 2010, so both should be 2010.

 

Since you now say Broken VI has re-surfaced, I want to know WHY the VI is broken. From your VI, I find nothing that should make it work in dev and not in RTE. So if the file opens in 2010 DE, it must work in 2010 RTE without issue.

Prashanth N
National Instruments
0 Kudos
Message 16 of 27
(226 Views)

Pachi, I will try it with a fresh vi made in LV2010 with a simple stop button.

 

I don't know if it counts: I first installed LV2011 on that machine and then after used the installer that I made in the teststand deployment with RT LV2010 as engine.

0 Kudos
Message 17 of 27
(222 Views)

My simple Stop button vi works perfect. But when I load my other vi in TST it's searching for some dependency. LVRectTypeDef.ctl ?

0 Kudos
Message 18 of 27
(221 Views)

When I use custom controls who are sitting a directory higher then the vi, the RT engine report a broken vi..?

0 Kudos
Message 19 of 27
(216 Views)

JoVMo,

I plan to replicate your setup here to make things easier. Can you tell me which version of Teststand you use? Also, tell me anything else about your setup that I might need to know. Which version of LV are u using to write the VI, to where you are calling it.

Prashanth N
National Instruments
0 Kudos
Message 20 of 27
(211 Views)