Showing results for 
Search instead for 
Did you mean: 

LV Compare error with Tortoise Git


I have just started using version control with Tortoise Git. I changed the Git settings to use LV compare and merge for diff and merge of tortoise git and made a change to a VI after a commit to see the difference. I incur a problem with launching LV compareLV compare error.JPG

 I added .vi extension to advanced diff settings with external program as "C:\Program Files\National Instruments\Shared\LabVIEW Compare\LVCompare.exe" %mine %base -nobdcosm -nobdpos

0 Kudos
Message 1 of 12

Did you check to verify that LVcompare works outside of TortoiseGit?  

0 Kudos
Message 2 of 12

It may not be the problem you are encountering, but LVCompare will run in the last context which was active in LabVIEW (which is a real PITA).


Could it be that you were working on a RT target before launching a compare?  This behaviour of LVCompare and LVMerge is extremely annoying because there's no reason whatsoever to run either of these on any target other than "My Conputer".  If this helps, please give Kudos HERE.

0 Kudos
Message 3 of 12

I tried it with command prompt and the same error recurs


Launching  from C:\Program Files\National Instruments\Shared\LabVIEW Compare\supportVIs\_prolvcmp.llb

gives the following error


An error occurred while running LVCompare.<ERR>

0 Kudos
Message 4 of 12

I am not working with Real Time at the moment

0 Kudos
Message 5 of 12

Why are you running the VI, there's an EXE isn't there? Under "National Instruments/Shared"....

0 Kudos
Message 6 of 12

I am trying everything to understand the problem. The exe causes error on launch and in command prompt with parameters

0 Kudos
Message 7 of 12

When you look at the error, it says it can't opent he ini file for settings.... could permissions on this folder (possibly on a network drive) be part of the problem?

0 Kudos
Message 8 of 12

The error occurs in my work computer where I use LV full development system whereas it does not occur in my personal computer where I use LV professional development system.


Could the version be the source of problem?


Message 9 of 12

@Kyle97330 wrote:

Did you check to verify that LVcompare works outside of TortoiseGit?  

I get that error from an MSYS2 terminal "git diff" with LabVIEW Professional Development System Version 2023 Q3 (32-bit) 23.3.1f1. C:\Users\<>\AppData\Local\Temp\LVCompare.ini does not exist (I have permissions and can create the file manually). The error message can be scrolled down to see the following.

<b>Complete call chain:</b>
NI_LVConfig.lvlib:Open Config

0 Kudos
Message 10 of 12