LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LV 8.5 Wfm chart, stacked plots BUG

Hi,

could anybody reproduce the bug I encountered?

 

When using stacked plots with wfm chart and in the event case structure 'Shortcut menu activation' I cannot independently change the autoscale settings of the Y axis.

To reproduce it:

1] run the VI

2] right click the y scale on the 2nd or 3rd plot and select/deselect autoscale of the y axis.

3] try to change the range of changed axis or of any others. You will figure out that wherever you changed it it was applied only on the axis of the 0 plot

4] erase the ''Shortcut menu activation' case and you will see that the autoscale starts to behave as expected

 

thanks

LV 2011, Win7
0 Kudos
Message 1 of 11
(3,029 Views)

You're right, It has the same behavoiur as you presented.

 

Mircea

0 Kudos
Message 2 of 11
(3,002 Views)
Hi,

Please remove the case "Waveform Chart: Shortcut Menu Activation" because when you use event structures you have to handle the events. By that it means that you actually take crontrol from LabVIEW on how to treat an event.
When you add an event case you have to treat it. In order to handle the event in your case you should use property nodes and invoke nodes to change the properties for the graphs.
The behavior that happens is normal due to the fact that the GUI interface interprets the event and there are 3 graphs that have this Autoscale option. If you want to treat the event, you should check which graph was the one that is supposed to be autoscaled and you do that, as I said, by using Invoke Nodes and Property Nodes.

This mechanism of treating events is similar to Windows Programming Model.

I hope this helps.
Let me know if there are any other questions.
0 Kudos
Message 3 of 11
(2,992 Views)
Hmmm, I have to disagree on that. What if I just want to disable some of the  menu items (which is exactly what I wanted to do when I encountered this)? Then the rest of the items should behave as expected, shouldn't it?
Message Edited by ceties on 01-29-2009 02:48 AM
LV 2011, Win7
0 Kudos
Message 4 of 11
(2,968 Views)
Hi,
I investigated more your question. I think I understand now what you ment.
I changed the VI a little - actually I only changed the case you handle to Scale Range Check.

Please check the attached VI.
0 Kudos
Message 5 of 11
(2,956 Views)
Hi I have LV8.5.1, could you please downgrade it? Thanks
LV 2011, Win7
0 Kudos
Message 6 of 11
(2,953 Views)

Attatched.

 

Let me know if there are questions.

0 Kudos
Message 7 of 11
(2,951 Views)
It doesn's solve the problem. Add the menu activation event of the chart and you face the same unexpected behaviour as before. I need to use that case (menu activation?) to enable/disable some menu items of the chart. I ofcourse coded some workaround but I still believe it is a bug!
LV 2011, Win7
0 Kudos
Message 8 of 11
(2,949 Views)
I managed to replicate.
Thank you for the information and taking the time for this.
I will investigate some more and report the problem further to R&D department and keep you up to date regarding this issue.

Kind regards,
Sebastian Bratescu
0 Kudos
Message 9 of 11
(2,946 Views)
Thanks for your time and let us know!
LV 2011, Win7
0 Kudos
Message 10 of 11
(2,927 Views)