Showing results for 
Search instead for 
Did you mean: 


Go to solution


My company has about 20 machines with various versions of LabVIEW installed.  I just realized that the NI Update Service utility has never ran on my main workstation, but it did on multiple lab machines.  I tried to fire up the NI Update Service manually, and I got this error message:


"National Instruments Update Service has been disabled by your administrator.  Contact your adminstrator for information about updates to Naitional Instruments products."


What?  I am the adminstrator!  I didn't disable anything...


I opened up the NI License Manager (V3.7), and saw this odd inactive server in the list:


NI License Manager - Bad Server.jpg


This is a FlexLM server that we are running, however as you can see, we are only running local licenses of LabVIEW.  We do not have a VLM setup for LabVIEW.  I tried to delete it by right clicking and selecting "Remove Volume License Server", and got this error message:


"This volume license server could not be removed due to an error writing to the registry or because this volume license server is specified in an environment variable"


Sure enough, I have LM_LICENSE_FILE user environment variable set to the server shown above.  However this variable is required by another set of software that does use a FlexLM server.  (Specifically, Mentor Graphics ModelSim.)


If I remove the LM_LICENSE_FILE string, then the NI License Manager will no longer show the inactive server, and NI Update Service runs as expected:


NI License Manager - No Server.jpg


Of course, by removing LM_LICENSE_FILE, my other software (ModelSim) will no longer work.


So my current workaround is to delete LM_LICENSE_FILE until NI Update Service is finished updating, and then add the environment variable back.  This is annoying, and looks like a bug.  Is there any other possible workaround/fix where I don't have to play games with LM_LICENSE_FILE?





0 Kudos
Message 1 of 6


I had a similiar issue that I resolved by completely uninstalling LabView, running a registry cleaner ( is free and awesome) and reinstall LabVIEW. It may be cheating, but it definitely worked.

0 Kudos
Message 2 of 6


An option, but maybe a bit too "nuclear".  Smiley Happy  I'd prefer to avoid reinstalling 6 versions of LabVIEW (32 bit & 64 bit) plus drivers.

0 Kudos
Message 3 of 6
Accepted by topic author AMPz
08-27-2015 04:09 PM


Hey AMPz,


This is occurring because the NI License Manager will look in a variety of locations for a volume license server: a certain registry key, the NILM_LICENSE_FILE environment variable, and LM_LICENSE_FILE environment variable. If it finds any servers in these three locations, it will assume there is a volume license server that can be accessed. If it cannot access the server at the current time, it will assume that updates are not allowed and will not allow you to run the NI Update Service. This is exactly what's happening here.


Fortunately, there is a solution. the LM_LICENSE_FILE environment variable is a general location for license servers and is looked at by multiple pieces of software (including ours), but most software also has a more specific environment variable. For your software, that variable appears to be: MGLS_LICENSE_FILE. Do you have this environment variable on your system, and if so, can you move the license server information to that variable? I think this might resolve the issue you're seeing.


Hopefully that will work, but if not, let us know and we can continue to look into it.

Daniel E.
TestStand Staff Product Support Engineer
National Instruments
Message 4 of 6


Removing LM_LICSENSE_FILE and just using MGLS_LICENSE_FILE worked.  Thanks!

0 Kudos
Message 5 of 6


I know this thread is pretty old, but I arrived at this accidentally when searching for my actual problem (slightly different), so in case someone else does the same, I wanted to add my 2 cents.   Working with LabVIEW 2014 on a standalone non-networked/non-internet connected laptop, I suddenly began getting startup times for LabVIEW in the minutes range.  Searching about slow startup times for LabVIEW lead nowhere as everyone kept suggesting making sure the license manager didn't have any expired licenses, which mine didn't.  I just happened to noticed my LM_LICENSE_FILE port/IP combo at the top of the NI License manager window, when looking for expired LabVIEW features, ... which led me down this path.  I also use some Mentor Graphics software on the laptop, which uses the LM_LICENSE_FILE variable, LabVIEW has always been a single user install.  So the LM_LICENSE_FILE variable was causing LabVIEW to search for volume licensing stuff for minutes, without saying anything about what it was doing, not giving any hint about that being the problem.  I removed the LM_LICENSE_FILE variable and that fixed the problem with LabVIEW, still gotta work out what to do with Mentor.  Looks like theres some solutions out there for this issue as well (think I might be able to use MGLS_LICENSE_FILE), but I just wanted to note, LM_LICENSE_FILE Conflicts can wreak havoc, even when you THINK you're not using them!



0 Kudos
Message 6 of 6