LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LINX 3.0 on the Raspberry Pi 2, 3 and 4 running Raspbian Buster

Hi Andy

 

Thank you so much for this post, help me a lot!!!

 

I would like to use this addon at raspberry pi 3 running raspbian buster  https://github.com/QWaveSystems/QwaveSys-Raspberry-Pi-Package/tree/master/%40Examples/Ex_DHTxx

I've been trying to install without success.

Do you know how can I install this addon on raspbian Buster?

 

 

Best Regards

Diogo Aparecido
Applications Engineer II
National Instruments Brazil



0 Kudos
Message 21 of 28
(656 Views)

Hi  RPCVEngineer, Diogo,
Thank you for your comments.
NI included the updated LINX toolkit package in LabVIEW 2020 Community Edition.
This is compatible with the lvrt20-schroot runtime on the Raspberry PI.
I don't know if NI include the updated LINX toolkit package in LabVIEW 2020 Professional Edition.
I think the LINX package available for download in the VI package manager is only compatible with LabVIEW 2014 for the Raspberry PI target.
Hopefully NI will update the package soon. 


I haven't tried the NI vision runtime on the Raspberry PI.

There is an OpenCV toolkit for LabVIEW running on the Raspberry PI as mentioned by Diogo Aparecido.

The manual install steps detailed at https://github.com/QWaveSystems/QwaveSys-Raspberry-Pi-Package/wiki/02.-Manual-steps-to-install-LabVI...
may work on the Buster version of Raspbian. if the procedure does not work it could be due to the different c++ compiler paths in the lvrt20-schroot.
It may be possible to compile the libraries using the original lvrt-schroot.

Cheers,
Andy.

0 Kudos
Message 22 of 28
(635 Views)

Hi Andy

 

 

 Thank you for your answer, I've already tried this step by step on lvrt-schroot without sucess, When I execute this command "cat /etc/opkg/arch.conf"  the results is: The file or directory doesn't exist

 

 

 

Diogo Aparecido
Applications Engineer II
National Instruments Brazil



0 Kudos
Message 23 of 28
(594 Views)

Thanks for posting this.  I used a Raspberry Pi 4B and all went OK!

0 Kudos
Message 24 of 28
(535 Views)

Thank you..Is LabVIEW 2020 compatible with Raspberry Pi4?

0 Kudos
Message 25 of 28
(417 Views)

People have successfully installed LINX on Pi 4 hardware.  But I think officially NI still doesn't support it.  That being said I've seen NI enthused to see LINX running on various non-official hardware.  I tried it and it seemed to work fine.

0 Kudos
Message 26 of 28
(413 Views)

Hi everybody, 

 

i have tried to make the actual version of Linx work on a RPI 2 & 4 with LV 2019 & 2020 following the guides mentioned in this thread. But i had no success at all. 

While trying to connect to the target, i get the following error message:

Bildschirmfoto 2020-07-31 um 10.42.37.png

Both RPIs were fresh installed with the actual image.

Has anyone an idea how to fix this?

 

thanks in advance!

 

best,

 

Norbert

0 Kudos
Message 27 of 28
(384 Views)

I use Labview 2015 ,how to control raspberry pi3 ?

0 Kudos
Message 28 of 28
(169 Views)