Showing results for 
Search instead for 
Did you mean: 

LINX 3.0 on the Raspberry Pi 2, 3 and 4 running Raspbian Buster

Hi Andy


Thank you so much for this post, help me a lot!!!


I would like to use this addon at raspberry pi 3 running raspbian buster

I've been trying to install without success.

Do you know how can I install this addon on raspbian Buster?



Best Regards

Diogo Aparecido
Applications Engineer II
National Instruments Brazil

0 Kudos
Message 21 of 31

Hi  RPCVEngineer, Diogo,
Thank you for your comments.
NI included the updated LINX toolkit package in LabVIEW 2020 Community Edition.
This is compatible with the lvrt20-schroot runtime on the Raspberry PI.
I don't know if NI include the updated LINX toolkit package in LabVIEW 2020 Professional Edition.
I think the LINX package available for download in the VI package manager is only compatible with LabVIEW 2014 for the Raspberry PI target.
Hopefully NI will update the package soon. 

I haven't tried the NI vision runtime on the Raspberry PI.

There is an OpenCV toolkit for LabVIEW running on the Raspberry PI as mentioned by Diogo Aparecido.

The manual install steps detailed at
may work on the Buster version of Raspbian. if the procedure does not work it could be due to the different c++ compiler paths in the lvrt20-schroot.
It may be possible to compile the libraries using the original lvrt-schroot.


0 Kudos
Message 22 of 31

Hi Andy



 Thank you for your answer, I've already tried this step by step on lvrt-schroot without sucess, When I execute this command "cat /etc/opkg/arch.conf"  the results is: The file or directory doesn't exist




Diogo Aparecido
Applications Engineer II
National Instruments Brazil

0 Kudos
Message 23 of 31

Thanks for posting this.  I used a Raspberry Pi 4B and all went OK!

0 Kudos
Message 24 of 31

Thank you..Is LabVIEW 2020 compatible with Raspberry Pi4?

0 Kudos
Message 25 of 31

People have successfully installed LINX on Pi 4 hardware.  But I think officially NI still doesn't support it.  That being said I've seen NI enthused to see LINX running on various non-official hardware.  I tried it and it seemed to work fine.

0 Kudos
Message 26 of 31

Hi everybody, 


i have tried to make the actual version of Linx work on a RPI 2 & 4 with LV 2019 & 2020 following the guides mentioned in this thread. But i had no success at all. 

While trying to connect to the target, i get the following error message:

Bildschirmfoto 2020-07-31 um 10.42.37.png

Both RPIs were fresh installed with the actual image.

Has anyone an idea how to fix this?


thanks in advance!





0 Kudos
Message 27 of 31

I use Labview 2015 ,how to control raspberry pi3 ?

0 Kudos
Message 28 of 31

hi to everyone,
I wish you could help me with my Raspy 2B and LV 2020 Community edition..
I run Windows 10Pro (20H2) on a Dell Latitude notebook and want to use a Raspy2B with LV. After multiple fruitless trials with the previous "free" LABVIEW (2014) and the different flavors of LINX 3 on my Raspy 2B, I finally decided to install the LV2020 community to communicate with the device. At first, everything seemed to run fine, it has changed when I have decided to run the Blink project.
In the LV project windows, the Raspy has its green dot but when launching the deployment of RPI2, the progress windows calls the Conflict resolution with "Unable to resolve from current dialog" and associated message "Failed to connect to the target". There, the only possible option is Cancel.
I tried to run the command-line install found earlier in this queue (Ady's message nr 11) :
- clean source.list -> OK
- lvrt-schroot is installed (version 14.1.11) -> OK
- moved the nisysserver.service and labview.service files to the systemctl folder -> OK
- link to the Raspberry PI device driver file -> NOK:
E: child terminated by signal 'Instruction non permise'
- Enable the nisysserver.service and labview.service to start on boot -> NOK:
Job for labview.service failed because the control process exited with error code.
-> systemctl status labview.service
● labview.service - LabVIEW chroot run-time daemon
Loaded: loaded (/lib/systemd/system/labview.service; enabled; vendor preset:
Active: failed (Result: exit-code) since Wed 2021-05-05 14:32:36 CEST; 1min 3
Process: 1346 ExecStartPre=/usr/sbin/ (code=exited, status=
Process: 1492 ExecStart=/usr/bin/schroot --run-session -c lv -- /etc/init.d/ni
Process: 1506 ExecStopPost=/usr/bin/schroot --end-session -c lv (code=exited,

mai 05 14:32:21 raspberrypi systemd[1]: Starting LabVIEW chroot run-time daemon.
mai 05 14:32:29 raspberrypi[1346]: lv
mai 05 14:32:29 raspberrypi schroot[1492]: pam_unix(schroot:session): session op
mai 05 14:32:32 raspberrypi systemd[1]: labview.service: Control process exited,
mai 05 14:32:36 raspberrypi systemd[1]: labview.service: Failed with result 'exi
mai 05 14:32:36 raspberrypi systemd[1]: Failed to start LabVIEW chroot run-time

I wonder where the problem comes from. Is the hardware inadequate ?

Looking forward to read your suggestions. Regards,


0 Kudos
Message 29 of 31

just to let you know that with a Raspy3B the same procedure is right but inadequate for Raspy2B -> linx 1/LV community 2020 is not adapted for any type of raspberry. Regards

0 Kudos
Message 30 of 31