Showing results for 
Search instead for 
Did you mean: 

LINX 3.0 on the Raspberry Pi 2, 3 and 4 running Raspbian Buster

Hi joni2001, Paramasivan, WayneZhou,

I think the errors you are getting are due to your /etc/apt/sources.list file.

The file should only have one reference to

The file contents can be viewed by entering the command
cat /etc/apt/sources.list

The contents of the file should be 
deb buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src buster main contrib non-free rpi
deb [trusted=yes] binary/


To edit the file you can use the command

sudo nano /etc/apt/sources.list

You can then continue the installation procedure by entering the commands

sudo apt-get update
# Install the LINX package. Error messages will be displayed for the
# nisysserver.service and labview.service
sudo apt-get install -y lvrt-schroot
# Move the nisysserver.service and labview.service files to the systemctl folder
sudo mv /etc/systemd/system/ /lib/systemd/system
sudo mv /etc/systemd/system/ /lib/systemd/system
# link to the Raspberry PI device driver file
sudo schroot -c labview -d /usr/lib -- ln -s
# Enable the nisysserver.service and labview.service to start on boot
sudo systemctl enable nisysserver.service
sudo systemctl enable labview.service
# Start the nisysserver.service and labview.service
sudo systemctl start nisysserver.service
sudo systemctl start labview.service


I recommend running the procedure detailed in my first post on a new installation of Raspbian Buster.

Hope this helps,



Message 11 of 31

Works perfectly on the raspberry pi 4b. Thanks!

0 Kudos
Message 12 of 31

I've tested this on Raspberry Pi 3 B with Buster and it works with LabView 19. I've used lvrt19-schroot and there was no error with the LabView services during installation on Raspberry so the final steps are not needed in this combination. Thank you 🙂

LabView 2019 with Raspberry Pi3BLabView 2019 with Raspberry Pi3B

0 Kudos
Message 13 of 31

Thank you very much for the code.

I have executed the instructions successfully on my Raspberry Pi 3B+.

But now I have the problem that my laptop couldn't connect to raspberry pi over Labview 2019.

I only get a connection with the windows remote App.

What have you undermeadow done that you can connect the raspberry with your Labview on your Laptop?

Because my Laptop does not find the target.

0 Kudos
Message 14 of 31


Hi lab19rasp,

LINX 3.0 on the Raspberry PI only supports LabVIEW 2014:


NI have a beta version of Labview 2020 Community Edition that includes a newer version of LINX.

There is more information at


There is an older NI LINX beta that supports LabVIEW 2019. Here is a link to a great blog that describes how to install it

0 Kudos
Message 15 of 31

To use LINX with LabVIEW 2019 you would need to have the LINX 2019 beta tool kit installed on the PC and lvrt19-schroot installed on the Raspberry Pi.

0 Kudos
Message 16 of 31

Hello AndyLB,


Thank you for your useful answers.

I could not find the LINX 2019 beta tool kit some where?




0 Kudos
Message 17 of 31

check the space is in front of " binary" not normally is a space there.. i left it out first try

0 Kudos
Message 18 of 31

After many trials of the above helps to use LINX with LV2020,  what seemed to work in my case was to use the below shown install line after the install had failed with "Dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)" from both LINX Target Configuration dialog driven install and the command line manual install.


I should note that the library I used which worked to connect to LV2020 was lvrt20-schroot


sudo dpkg -i --force-overwrite /var/cache/apt/archives/lvrt20-schroot_20.0.0-3_armhf.deb



0 Kudos
Message 19 of 31

Hi Andy!


The instructions worked for LabVIEW 2020 Community Edition, but doesn't seem to work for LabVIEW 2020 Professional Edition. In addition, is there a way to install necessary software like vision runtime onto the rasp pi 4?



0 Kudos
Message 20 of 31