Showing results for 
Search instead for 
Did you mean: 

Kiethley 6517B Error 803



I am trying to make a graph of current VS. Time using LabVIEW software. I have the electrometer connected by an RS-232 serial connection. To start I downloaded all the instrument drivers from NI (via. NI Max). I have tried running the example Aquire Measurement, which gives me a reading the first run. If I try to run it again I get Error 803 (RS-232 on the Electrometer. I have to fully close the program to get it to run successfully again. 


In the VISA test panel, all attributes are fine except the last which gives me an error "Hex 0xBFFF001D - the specified attrubute is not defined or supported by the referenced resource." 


I don't know if these are related, but anyway to fix or bypass this error would be appreciated.



0 Kudos
Message 1 of 5

What model 6517 are you using A/B?


I usually use GPIB, so I've never seen this with model A. The manual says Error 803 is " RS-232 Break detected".  Which sort of sounds like a termination character setting isn't right, or you haven't read all the data from the measurement buffer before trying to do something else.  Make sure the RS232 com settings match the values you specify in LabVIEW.  Make sure you have a straight thru RS232 cable.

Are you using the latest version of the LabVIEW driver?  It might be there's a know issue in older version that was fixed.    


What about just sending the SCPI command in a loop?  Just use VISA WRITE to send the command ":SENS:DATA:FRES?;" (to get a new measurement) and then use VISA Read read back a string.  (VISA Read requires a hint about maximum reading size so use something big like 10000 bytes.) 


Do this in a loop and see if you get the error.  See if the first and second strings have the same number of characters, same terminations or extra junk at either end.  



0 Kudos
Message 2 of 5

The error 803 appears when using the NI-provided initialize VI of the driver, specifically at the CLR instruction below (snippet)







I tried to put the serial interface configuration before the CLR, but to no avail, the message is still displayed. It doesn't seem to have an incidence on the working of the instrument afterward, so maybe this is not critical


Has anybody observed this with the GPIB connection?





0 Kudos
Message 3 of 5

OK, so I think I found where this problem appears, so I'm posting for others as it seems to be quite common with this instrument


I'm using Keithley 6517A on a USB to serial cable on my laptop


Here is a snippet of a test VI I've done



All serial parameters have been checked on the instrument. 

I can make appear the error 803 when I'm selecting the CLR fonction with the case structure. It seems to queue a 803 error "RS-232 Break detected" and a 804 error "noise detected"

Upon various successive executions, the error queue fills up


If I select the Serial buffer (IN) flush or if I deactivate completely the case structure, I do NOT generate the 803 error, and I get the correct state "No error" message from my command.


If I first generate an error 803 using the CLR command, then read the error queue without using CLR at any moment, then I retrieve the error messages that were queued and I finally flush the queue from all the errors



The 6517A (or B probably) do not accept the CLR command when communicating with serial, which makes the standard driver by NI unusuable in its as downloaded state. One should add a case structure around the CLR commands to keep it from executing when using RS232. It is probably useful for GPIB but I couldn't test it


I hope this is going to be useful

Message 4 of 5

The difference between CLR and serial buffer IO flush is detailed in the following discussion:


VISA Clear Vs Flush Buffer for RS-232 - NI Community

Message 5 of 5