LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Keithley 6221/2182A Delta Mode Example

Solved!
Go to solution
Highlighted

Hi, I'm trying to set up the delta mode example from the Keithley 6221/2182A example, and I'm receiving this error:

 

KE622X Configure Delta Mode.vi<ERR>
Driver Status: (Hex 0xBFFF0015) Timeout expired before operation completed.

Secondary Error: (Hex 0xBFFC0004) Parameter 4 out of range, or error occurred while setting Parameter 4.

Elaboration: Resolution

 

For reference, I had also tried running the DC example and that worked fine. I suspect that there is some issue with the connection between the voltmeter and the ammeter. As far as I can tell, the trigger cable seems to be connected. The RS-232 ports are being connected by a CA-351A null modem cable, so perhaps that the issue?

 

I have attached pictures of the example vis 

0 Kudos
Message 1 of 13
(154 Views)

Hi @Chong_X,

 

Which function/VI in the screenshot you sent is throwing the error? Also, is there any further elaboration on what Parameter 4 actually refers to?

 

In terms of the cable, the manual should tell you whether or not a null modem cable is suitable for the instrument.

Lindsey Nestor
Technical Support Engineer
National Instruments
0 Kudos
Message 2 of 13
(121 Views)

Hi

If you have the TTL cable and the RS232 connection between 6221 and 2182, you can use the following vi which I wrote many years ago. It is ugly, slow, but works. This will start delta mode. Read the date with Visa call SENSSmiley Very HappyATA:FRESh?

stop delta with Visa call ABORt

good luck

 

 

0 Kudos
Message 3 of 13
(117 Views)

Sorry for the delayed response.

 

The VI that's throwing the error is the configure delta mode VI, and parameter 4 seems to be the compliance limit voltage parameter. I've attached the original delta mode example VI, as well as the configure delta VI. 

 

I believe that I read in the manual that the cord I was using is the appropriate one, and it fits the connection, but I'll double check with a different cord.

0 Kudos
Message 4 of 13
(98 Views)

Thank you for your help. I did try running the VI, and unfortunately it seems like I was unable to successfully execute it. The error that I got was this: VISA Write in ke622x_2182a_setdelta.vi

 

I'm thinking that there's an issue with how I've connected my devices, but I'd appreciate it a lot if you have some insight on where the issue with my setup is based on the error I got. 

0 Kudos
Message 5 of 13
(97 Views)

Hi

This routine works well for many years in my case. What is the exact error ?

You can probe to see which command does not work, but I suspect one of the following :

-Visa address

-RS 232 cable not connected to the 2182

-no TTL cable link ?

give more details if you want to get help

0 Kudos
Message 6 of 13
(95 Views)

Sorry, I'm rather new to labview so I didn't realize that there were a lot of VISA Writes. I followed the VI through its execution and saw that the error began at the first VISA write function, the one writing *RST to the buffer. I've attached a picture of the specific function. 

 

I personally don't think that the visa address is the issue, because I was able to run the DC example VI from keithley on the same visa address and see a response in the ammeter.

 

The RS232 and the TTL cable links are plugged in, but I think it's possible that they're not connecting. I'll look for new cables and see if they make a difference tomorrow.

 

 

0 Kudos
Message 7 of 13
(92 Views)

In order to see if the 6221 and 2182 are connected just do this :

-press DELTA on the 6221

-it will ask you to press Trigger, so then press TRG on 6221

If connection OK you should see the measurements listed on the 6221

Can you confirm this ?

N

0 Kudos
Message 8 of 13
(88 Views)

I pressed delta, and then trig on the 6221, and the 6221 says overflow, and indicates the source current and compliance voltage. 

 

The 2182a just says delta mode. 

 

I've attached pictures of the displays on both. Would this indicate that they are not connected?

0 Kudos
Message 9 of 13
(83 Views)

No, that indicates that the two devices are connected and they are working (overflow and compliance come from the fact that probably you do not have connected a resistor to measure it).

So, I am still thinking that it must ne the GPIB address (what is the GPIB address you have on 6221 ?) When you start the 6221 it will list the GPIB address. Make sure is the same as the one put in the software I sent

0 Kudos
Message 10 of 13
(80 Views)