LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Issues with building a VI into a .exe in Labview 2016

Highlighted

Hello,

I am trying to build a VI I have created into and executable. Unfortunately my computer seems to be having issues with this. I have sent my VI to a coworker and he was able to build it into an executable without any issues. I have checked my licenses and they are all up-to-date. I have tried to do this with all windows closed, except the build window and project window, I have even restarted my PC, and still no luck. I keep getting these errors:

Error 8 occurred at Copy in AB_Engine_Copy_Error_Files.vi->AB_Application.lvclass:Copy_Error_Files.vi->AB_Application.lvclass:Copy_Files.vi->AB_EXE.lvclass:Copy_Files.vi->AB_Build.lvclass:Build.vi->AB_Application.lvclass:Build.vi->AB_EXE.lvclass:Build.vi->AB_Build.lvclass:Build_from_Wizard.vi->AB_UI_Frmwk_Build.lvclass:Build.vi->AB_UI_FRAMEWORK.vi->AB_Create_Build_Application.vi->EBUIP_Global_OnCommand.vi->EBUIP_Global_OnCommand.vi.ProxyCaller

Possible reason(s):

LabVIEW: File permission error. You do not have the correct permissions for the file.

C:\Program Files (x86)\National Instruments\Shared\LabVIEW Run-Time\2016\errors\VI-Analyzer-errors.txt

 

My file is not set to Read-Only and I have full Admin permissions. Any ideas?

 

Thank you.

0 Kudos
Message 1 of 11
(197 Views)

Where are you trying to save the Build?  You should not use Program Files or Program Files (x86) as output directories.

 

Bob Schor

0 Kudos
Message 2 of 11
(168 Views)

I have tried a few different locations. One time my desktop, another was my project folder on my C drive. I never tried to output to my program files.

0 Kudos
Message 3 of 11
(165 Views)

I still have not found a solution. Any help would be greatly appreciated. Maybe a reinstall is the next step. My coworkers have no trouble at all building my vi into an executable.

0 Kudos
Message 4 of 11
(121 Views)

This is a "long shot", but is it possible you might have a License issue (something didn't get activated)?  Go to the Start Menu, National Instruments, and look in the folder for NI License Manager.  Run it and be sure everything says "Activated".  Note that mine shows "Application Builder" as a separate "thing to activate".License Manager.pngLicense Manager

Bob Schor

 

0 Kudos
Message 5 of 11
(115 Views)

Try this.

 

Create a new project.

Add a blank VI, save it.

Create a new executable only changing the build specs to choose your blank VI as the startup VI.

Hit OK

Save the project

Right-click and try to build this executable.

 

Does it build successfully?  (This shows you have the capability TO build an executable.)

 

Essentially, the goal of this step is it's trivial effort and it tells you if the build is an issue with your specific project or if it's with building in general.

 

If that builds, does your project build on your colleague's PCs?  You said they can build things but didn't specify it was this same project.

0 Kudos
Message 6 of 11
(108 Views)

Some other possibilities:

 

- Some overzealous antivirus software.

- Disk errors/corruption.

- corrupted LabVIEW install.

- malware

- ...


LabVIEW Champion Do more with less code and in less time
0 Kudos
Message 7 of 11
(100 Views)

Here is my license manager.

 

123.PNG

0 Kudos
Message 8 of 11
(90 Views)

I attempted to build a blank vi and received the same errors.

 

My colleagues can successfully build my project. I sent it to them to build for me. The issue is definitely localized to my PC.

0 Kudos
Message 9 of 11
(88 Views)

Now that you have isolated the problem ie your computer and your setup, next logical step would be to re-install LabVIEW to see if that fixes the problem.

Let us know how it goes.

0 Kudos
Message 10 of 11
(80 Views)