LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Issue in displaying data

I am getting 2 inputs TTL from hardware and comparing these inputs one by one , when I compare inputs as a result it shows true or false .

But the problem is that when I compare first input the result is true so it displays true  but as I check second input it shows true but showing First input false although it was true.

So how to display both result current status.

I want to check status only when I am comparing inputs.

0 Kudos
Message 1 of 4
(830 Views)

Hi SR,

 

I want to check status only when I am comparing inputs.

THINK DATAFLOW and everything else will fall into place!

Smiley Very Happy

 

For a more detailed answer you need to attach your VI because your explanation of the problem is hard to understand (atleast for me)!

 

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

0 Kudos
Message 2 of 4
(821 Views)

Pic1.1:  writing LOGIC 1 to following inputs 

Pic2.2 : reading inputs and comparing 

Pic 3.3: displaying result.

 

0 Kudos
Message 3 of 4
(808 Views)

Hi SR,

 

I still don't know what you want to achieve…

 

I do know now:

- you're using way too much local variables: use more wires instead!

- you're using too many sequence frames/structures: THINK DATAFLOW!

- you're producing Rube-Goldbarg/nonsense code: what's the point of ANDing a value with itself?

- from what I see your code is subject to race-conditions: why are there two places that write into the same local variable?

 

Why don't you clean up your code?

Did you take the free beginner courses offered by NI online?

 

Why don't you attach your code? We cannot debug images!

(And we cannot get the overview of all your code just from small "snippets"…)

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

0 Kudos
Message 4 of 4
(774 Views)