LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Issue adding timestamps to array

Solved!
Go to solution
Highlighted

Hello,

I'm attempting to augment a VI available from ATI to read a 6 axis sensor, and am having issues adding timestamps to each row of data. I can currently add timestamps, but they appear in a row below the force and torque data. I would like them to appear in the 1st column, and the data to be added to the subsequent columns (see below):

 

what I have:

image 1.JPG

What I would like:

image 2.JPG

 

I have included the VI (not sure if all the sub VI's are needed), and they part I'm augmenting is to the right in the block diagram. Last time I worked with labVIEW was 2 years ago, and I am a bit over my head. I apologize for the inputs to some of the array tools, I have been searching the forums piecing together previous solutions and help so I don't understand everything I have done here.

image 3.JPG

Additionally, if anyone can help me understand the "index into array" function, specifically in regards to "index 0...n-1" I would be very grateful. I feel like that is the key here, as it states that I can insert arrays into specific columns by wiring 3 to a specific index input, but I have no idea what they are referring to.

 

Thank you very much for the time and patience.

 

 

0 Kudos
Message 1 of 3
(563 Views)
Highlighted
Solution
Accepted by topic author CBlevins

The problem is your are creating a1-D array of of time/date, have a 2-D array of values converted to as 2-D string array.  Then concatenate the 1-D array to the bottom of the 2-D array.

 

Also, it is rather pointless to insert a string of date/time into an empty 1-D array.  It just leaves you a 1 element 1-D array.

There is also an easier way to format the current time into as String.

 

 augment_atidaqftmx_BD

Message 2 of 3
(556 Views)
Highlighted

Hello RavensFan,

 

Thank you very much for your prompt reply and help, I appreciate it. I changed the program per your recommendation and it worked as desired (I did flip the time and data inputs so that the time appears before the data).

0 Kudos
Message 3 of 3
(512 Views)