LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Ismatec Reglo ICC calibration

Hello everybody,

 

I'm trying to integrate a Ismatec Reglo ICC peristaltic pump in LabView. 

Everything works fine (starting, stopping, etc.) except starting the calibration.

Does anyone have some experience with any Ismatec pump and the correct order of the commands which are needed to start the calibration?

 

The commands I used so far are

 

- set to volume (over time) mode (G)

- set calibration volume (xU)

- set calibration time (xW)

- set calibration orientation (xR)

- start calibration (xY)

 

every command is confirmed by "*" except the "start calibration" command which results in "-" and the error code 7001 (which is written in the low level diver, downloaded from the Ismatec homepage)

 

Thanks for your help!

0 Kudos
Message 1 of 2
(1,640 Views)

Hello,

 

the problem could be related to at least two things:

  1. Either your way of communicating with the device is incorrect in this case contact the manufacturer and ask which command to send and if this device supports this command.
  2. If you are sure that this works then we can make sure that you do everything right from the LabVIEW part. In this case please make sure that you give the community a real change to help you (example VI, protocol, manufacturer documentation, error codes, LabVIEW & driver versions)

Regards,

Christoph

Staff Applications Engineer
National Instruments
Certified LabVIEW Developer (CLD), Certified LabVIEW Embedded Systems Developer (CLED)


Don't forget Kudos for Good Answers, and Mark a solution if your problem is solved
0 Kudos
Message 2 of 2
(1,587 Views)