Showing results for 
Search instead for 
Did you mean: 

Interface Not Found Error when Using Snap Example for Firewire (IEEE 1394)

Go to solution

I just recently installed a SONY XCD-SX910 to interface with Labview 8.2.  When choosing the driver, only the Legacy driver would work for the Firewire(R) (or IEEE 1394) installation.  After installing the driver, I successfully acquired images from the MAX inteface.  However, when attempting to trace through the 1394 Legacy Snap Example from the IEEE 1394 installation document, I am receiving the error "Interface Not Found".  I have tried a few iterations attempting to name the camera such as "cam0" (the name assigned to the camera in MAX) and "cam0 : SONY XCD-SX910".  However, the error persists.


What should I name my camera for it to find the interface?  Is there another underlying problem that is not obvious?



0 Kudos
Message 1 of 4

Is the Legacy Snap example you are referring to the one that is seen here: Can you post screenshots from both Measurement & Automation Explorer and the VI you are trying to use? Also, can you verify in Measurement & Automation explorer that you are using the 1394 driver? You can do this by right clicking your camer and the selecting driver and choosing the appropriate one. Some more information on all that you are seeing would help in order to troubleshoot this.



0 Kudos
Message 2 of 4

I partially solved my problem myself... I copied the I/O input for the camera name from a snap example; however, I cannot find the device from the menu.  Where is it?  It is a pull-down menu with an I/O on the side.


Once I chose that, it worked!

0 Kudos
Message 3 of 4
Accepted by topic author reuterra
The I/O control is not something that will populate when using the Legacy 1394 driver. If you are using IMAQdx as your driver, it will populate. Thus, when using the Legacy 1394 driver, you will have a string control on your front panel. When using the string control, you will have to set the camera name as "cam0" as you did before. As long as this matches what is in Measurement & Automation Explorer, you should be good as long as MAX is using the same driver that you are trying to use.
Message 4 of 4