LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Intensity graph

Hello dear community,

 

I want to plot an intensity graph for the study of a transistor as you can see in the picture attached .

I writed a program but it doesn"t work since I m beginner in Labview, can someone please help?

 

You can find the program attached to this post

 

Thanks in advance for your help!

 

0 Kudos
Message 1 of 8
(500 Views)

Hi Abdou,

 

it doesn"t work since I m beginner in Labview

It's because you missed to THINK DATAFLOW - the basic principle in LabVIEW!

 

Did you take those free beginner resources offered in the header of the LabVIEW board to learn LabVIEW?

 

Solution:

- get rid of DDT wires, either by using plain DAQmx functions or by converting the DDT wire to "nice" datatypes using FromDDT

- put the ExpressVIs into the loop: THINK DATAFLOW!

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

0 Kudos
Message 2 of 8
(483 Views)

Thank you so much for your answer!

 

I only saw some videos about LabVIEW but thank you for this tool it s amazing now I understand why I should put them into the loop

I didn't get this : 

get rid of DDT wires, either by using plain DAQmx functions or by converting the DDT wire to "nice" datatypes using FromDDT

 

 Can you please do it for me? I have deadline..

i Aattached the program

Thanks again!

 

 

0 Kudos
Message 3 of 8
(454 Views)

sorry it s not the correct VI

Please find attached the new one

0 Kudos
Message 4 of 8
(450 Views)

Hi Abdou,

 

your VI is using the DAQAssistent to read 100 samples from two channels.

Then you display those 2×100 elements in an intensity graph.

 

This VI runs exactly as you have programmed it. What's wrong with it?

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

0 Kudos
Message 5 of 8
(434 Views)

I still can't find the graph! 

 

I did the modifications you told me to do as you can see in the VI, is that good?

0 Kudos
Message 6 of 8
(427 Views)

Hi Abdou,

 

I did the modifications you told me to do as you can see in the VI, is that good?

It gets better - but is far from "good"…

 

- Your DAQAssistent is set to read 1k samples at 10kHz samplerate, but you only use one sample of each channel!? Why not read just 1 sample with 10Hz?

- Your samples represent analogue voltages, but you use them as indices into an array: which element do you want to replace when the voltage signals return 3.5V?

- To know if your VI is "good" you need to run it: do you get the desired results?

 

To "get rid of ExpressVIs and DDT" you might read this about DAQmx!

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

0 Kudos
Message 7 of 8
(422 Views)
Highlighted

Thanks for this explanations!

 

-Actually I want to plot the graph attached here, so do you think I should one sample or 1K and how?

-I didn't know my simples are indices because I want their values in the array to plot the graph but when I used fromDDT it s the only wire that I can use...

Can you please modify that in the VI attached because I need to do it today or give me your watsup please? I will really appreciate that

Thank you

0 Kudos
Message 8 of 8
(408 Views)