LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Installing problem for Labview 7.1 Real time module for RTX

Hi,

I was trying to install the Labview 7.1 Real time module for RTX on my windows-xp (service pack 2) machine. I am getting stuck because of the error: "You must have RTX 5.5 or later installed before installing this product". Do I need to install RTX 5.5 or later version? Where can I get it?

thanks and regards,

Rashmi
0 Kudos
Message 1 of 6
(2,820 Views)
RTX is not compatible with all the desktop pcs. Check this link
0 Kudos
Message 2 of 6
(2,802 Views)

Hi rashmi2104,

 

What Real-Time target are you intending to deploy to for your system? If you want to target another part of your host computer, then you should be using LabVIEW Real-Time for RTX, but if you are planning to target an external hardware target, you should use LabVIEW Real-Time for ETS. See here for more information on the difference between RTX and ETS.

 

If you actually want to use the LabVIEW Real-Time Module for ETS, as I expect if you do not have RTX installed, then there should either be a choice during the installation process to install the ETS version, or a separate disk that will be marked as ETS.

 

Regards,

Stephen S.

National Instruments
Applications Engineering
0 Kudos
Message 3 of 6
(2,790 Views)

Hi Stephen,

 

Thanks for your help.

 

We are developing a HILS setup for testing of MAV(mini aerial vehicle). I have developed a Labview VI for simulation of aircraft equations. Simulation loop is used for solving 12 ODEs with control inputs given through GUI and outputs are plotted on waveform chart. I have run the program offline with 0.001s step size and RK 4th method. It works fine. I would like to run the simulation in real-time to check whether each step calculation is completed within 1 ms or not. I have not interfaced any hardware target yet. Once we are satisfied with the real time performance of the LabView VI, then we will interface our actual hardware into the loop.

 

Can I use Labview Real-time RTX for this purpose?

 

Thanking you once again,

 

Rashmi

0 Kudos
Message 4 of 6
(2,764 Views)

Hi Rashmi2104,

 

LabVIEW Real-Time with Real-Time eXtensions (RTX) for Windows 2000/XP will not work for a computer running Windows XP SP 2 or later as you indicated in your first post.  Muks' link has this info.

0 Kudos
Message 5 of 6
(2,743 Views)

Hi where can i get the RTX 5.5 or later version?

0 Kudos
Message 6 of 6
(2,564 Views)