LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Installing Multiple Xilinx Compilers

Highlighted

I am having some problems with Xilinx IP and Xilinx tools installed. Specifically, some example use older versions of the Xilinx IP, if I want to modify them, I get an error saying I need Xilinx x.x tools installed. Well I go to the NI site download the x.x tools and install. (On the add remove programs the new tools show up in NIs software, so I believe they installed correctly.)

 

After installation I still get the same error stating that I need Xilinx x.x tools installed. What am I missing here?

 

Thanks

mcduff

0 Kudos
Message 1 of 5
(1,372 Views)
Highlighted

mcduff, which specific examples are you looking at?  Also, what Xilinx tools version are you downloading and installing?

0 Kudos
Message 2 of 5
(1,308 Views)
Highlighted

On my system, LabVIEW 2015 SP1 I installed Vivado 2014.4 tools and Xilinx ISE 14.7 tools, I can see this through the Add/Install programs feature.

 

I am looking at the example http://www.ni.com/example/31525/en/

 

If I try to configure any of the Xilinx IP it gives an error message and says I need the Xilinx 14.7 Compilation tool. Did I install the wrong one?

 

Thanks

mcduff

0 Kudos
Message 3 of 5
(1,304 Views)
Highlighted

looks like you have the Xilinx tools installed.  I am wondering if it could be due to you having both Vivado and Xilinx that it is having issues/getting confused.  Do you need both due to the hardware you are compiling for?  Might be worth uninstalling the one you don't need if that's an option.

0 Kudos
Message 4 of 5
(1,283 Views)
Highlighted

Ideally, what I would like to do is modify some of the examples that include Xilinx IP nodes. Unfortunately, different version do not map 1 to 1. I guess I need to figure out how out how to use the new versions.

 

Thanks for your help.

 

Regards,

mcduff

0 Kudos
Message 5 of 5
(1,274 Views)