LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Installing LINX, error 66

Hi,

 

I try to install Digilent LINX (Control Arduino, Raspberry Pi, BeagleBone and more) v3.0.1.192. But…

 

  • VIPM starts installation (LabVIEW 2014 is selected);
  • LabVIEW 2014 opens;
  • LabVIEW crash dialog pops-up (but VIPM stays running); the dialog says

Exception: Access violation (0xC0000005) at EIP=0x053B9498

Version: 14.0.1f11 (32-bit)

  • Shorty after LabVIEW crash VIPM shows “VIPM could not install the package…”
  • I press “Error Details” and see:

Main Package Name: Digilent LINX (Control Arduino, Raspberry Pi, BeagleBone and more) v3.0.1.192

Package Name with Error: Digilent LINX (Control Arduino, Raspberry Pi, BeagleBone and more) v3.0.1.192

Error Message: VIPM could not install the package lvh_linx-3.0.1.192 .

Error Code: 66

Error Source: Invoke Node in Set Control Value {Variant}__ogtk.vi->3867D436DD15F1029E2CFB78BC266B3D->9159A2A3D9C37FCA34AA5FB71955E400->4D0A1F39E16B972C81E5579AA1692697->OGPM Class.lvlib:36A369576D50AC7F094F1B1EC384777F->OGPM Class.lvlib:408245E2B0A5DF321D6A03C68C252F32->A89B07CECE1AA7D54D74F73EE344AC2B->VIPM Main Window.vi

===============

 

  • The same problem appears if I try to install this package in later versions of LabVIEW in the same computer: 2016, 2017, 2018.
  • The same problem appears if I download the package first, then install.

 

So I tried with another computer (very bad one to be frank). The package was installed in LabVIEW 2017 at the first try. This is in computer that is order of magnitude worse than the first one (while both are running under Windows 7).

 

Could you advice how to solve this problem? The second computer is too bad and cannot be used for regular work. I have it only to test how my solutions run in a really slow system.

 

Thank you

_____________________________________
www.azinterface.net - Interface-based multiple inheritance for LabVIEW OOP
0 Kudos
Message 1 of 4
(1,429 Views)
I have the same problem, I don't know how to solve it. I am on other computers, and the installation can be completed successfully without errors. It is certain that there is something wrong with the faulty computer system. I hope someone can answer it!
0 Kudos
Message 2 of 4
(1,069 Views)

I found about this in a NI forum discussion that was posted earlier. Below link explains the error.

 

http://stackoverflow.com/questions/5303524/what-exactly-is-the-scope-of-access-violation-0xc0000005

 

-Rahul

Hit KUDOS for Thanks

0 Kudos
Message 3 of 4
(1,046 Views)

Dear users,

 

I have the same problem, the only thing that worked for me (I am running LabVIEW version 2013, 32 bits) was installing an earlier version as suggested here:

 

https://www.feeds.labviewmakerhub.com/forums/viewtopic.php?f=12&t=506&start=30

 

However there is no explanation in that URL on how to do it so I explain it here:

 

Some tips first: It may help to run first NI update service until there are no more updates you are allowed to install with your license. In case it happens the same as me here, that there is also always an error, you can download those updates manually, reply below if you also need help with that.

I also read somewhere that you should have the "LabVIEW Interface for Arduino" NOT installed. You can check it inside VI Package Manager, after step (b) below

 

NOTE: Steps (a) and the following (b) and (c) may not be necessary but I add them here just in case.

 

(a) Download and install VIPM from here: https://www.vipm.io/download/

 

(b) Right-click on the VI Package Manager and click on run as administrator, it will ask you if you want to allow it and you click yes.

 

(c) Use the search box in the VI Package Manager to find and install MakerHub Toolboox

 

(d) Download version 2.0.0.93 of LINX from here:

 

http://download.ni.com/evaluation/labview/lvtn/vipm/packages/lvh_linx/

 

(e) Go to where the file is located in your computer, right-click it and select "open with VIPM library" and you follow the easy steps for installation.

 

Please let me know if you solved the problem this way. Or perhaps you have a better solution that works with the latest version on LINX!

 

Thanks

Regards

 

Marcelo

0 Kudos
Message 4 of 4
(423 Views)