Showing results for 
Search instead for 
Did you mean: 

Installer Select Source Dialog - looking for other installers of mine

Go to solution

I understand that when you are trying to build an installer, LabVIEW will prompt for you to point to additional installer media if it can't be found. However, I can't find any help for why it might be looking for other installers that I've built! I've attached a screenshot.

Annotation 2020-01-28 155645.png

It's asking me to provide installers for other applications that I've written that have nothing to do with this project! There is nothing from either of those listed in the dependencies. Why is it wanting the NI System Components from those?!

0 Kudos
Message 1 of 6

The answer might be laying in below link.

0 Kudos
Message 2 of 6
Accepted by topic author michael.lambert

The theory in that link is certainly helpful to understand. However, I ended up having to completely refresh the install of LabVIEW to get rid of the issue. Not fun, but at least it fixed it.

0 Kudos
Message 3 of 6

I'm also having this problem.  Can you give some more details on how you fixed this?  What do you mean "completely refresh the install of LabVIEW"?

0 Kudos
Message 4 of 6

Well depending on the version of LabVIEW you have, there's different ways of going about it. I think I was using 2017, so NI Package Manager was installed. I used NIPM to uninstall every single thing I could and installed from scratch... If you're using older versions, you'd probably go through control panel >> add/remove programs instead.


Moving forward, I just try to avoid running custom installers on any PC I plan to develop on to prevent this from happening.

0 Kudos
Message 5 of 6
Accepted by topic author michael.lambert

Holy cow that's some "work around."  I hope someone at NI is following this.


I did figure out another solution.  I searched my registry for the missing installer and found a reference to it in Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\National Instruments\Common\Installer\Distributions


I deleted all the distribution keys associated with that installer, and tried rebuilding.  I got prompted again for the missing "NI System Components", but this time, 'select source' was asking for "NI mx LabVIEW Control Installer."  I googled this and found this:


I deleted the directory C:\ProgramData\National Instruments\NI-DAQmx (had to stop all NI services to do this), then repaired DAQmx (none of the other recommended packages), rebooted, tried rebuilding again, and presto boomo it worked.


Hopefully this helps anyone else out there struggling with this problem.

0 Kudos
Message 6 of 6