LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Installation LabVIEW-Scilab-Gateway. LabVIEW not detected.

Bonjour,

 

L'installation de la dernière version de "Scilab - LabVIEW Gateway Software" à partir de LabVIEW-Scilab-Gateway.exe me propose le choix de la langue pour l'installation puis affiche le message: LabVIEW not detected. Installation aborted.

Suite à cela, j'ai mis LabVIEW-Scilab-Gateway.exe dans le même répertoire que LabVIEW.exe de 2009 puis 2010. Même résultat.

Pour infos, une application LabVIEW utilisant la dll ScriptScilab.dll de la version précédente de "Scilab - LabVIEW Gateway Software" fonctionne avec scilab-5.2.0 et scilab-5.3.0.

Cette version précédente était un zip et non un exe.

Configuration:

PC sous XP SP3

Labview FDS 2009 9.0.1 (32 bits) installé

Labview FDS 2010 10.0f2 (32 bits) installé et réinstallé

scilab-5.3.0 installé

Une idée pour résoudre ce problème? (qui pour l'instant n'en n'est pas vraiment un)

Syned.

0 Kudos
Message 1 of 11
(1,294 Views)
Highlighted

Bonjour Syned,

Nous avons découvert ce problème il y a des jours.  Il semble qu'il ne soit qu'un problème avec Windows XP.  Je pense que nous avons trouvé une solution, mais vous aurez besoin d'un nouvel EXE.  J'éspere savoir plus demain.

Because this is the English forum, I will also answer in English: We discovered this problem a few days ago.  It seems that it's only a problem with Windows XP.  I think we've found a solution, but it will require a new installer.  I should know more tomorrow.

Grant M.
Senior Software Engineer | National Instruments

0 Kudos
Message 2 of 11
(1,281 Views)

Merci pour cette réponse rapide (qui me rassure).

Pour moi rien ne presse.

J'attends le nouvel exe.

 

Syned

 

Désolé pour l'erreur de forum

0 Kudos
Message 3 of 11
(1,277 Views)

Hi,

 

I have the same problem. I am working with Labview 2009 and Windows XP.

Do you have any news about the new EXE? When should it be available?

 

Thank you.

 

Clement Malric

0 Kudos
Message 4 of 11
(1,213 Views)

Hello Clement and Syned,

We have fixed the installer for Windows XP.  It took a little time for the request to funnel through our web update procedure, but you can now download the updated LabVIEW to Scilab Gateway installers from http://bit.ly/ScilabLabVIEW.

Grant M.
Senior Software Engineer | National Instruments

0 Kudos
Message 5 of 11
(1,160 Views)

Labview-Scilab-Gateway ends up with "Labview not detected" message.

 

and the link to the fix " http://bit.ly/ScilabLabVIEW." given by Grant M. / 
Senior Software Engineer is broken.....

 

Can you redirect me (or us) ?

 

Thanks

0 Kudos
Message 6 of 11
(922 Views)

Simply remove the period at the end of the broken URL.

 

I'll have the moderator fix it.


LabVIEW Champion Do more with less code and in less time
0 Kudos
Message 7 of 11
(918 Views)

Thank you for the reply but that was not the problem, the link to http://www.ni.com/white-paper/5597/en was OK, I downloaded labview_scilab_script_node.zip sucessfully.

 

The problem I have is the messageBox "LabVIEW not detected. Installation aborted." with one button "OK" 

This MessageBox prevents me from installing the Gateway....

 

PS

Software are:

win XP (updated)

Labview 2011,

Matlab 2010b

0 Kudos
Message 8 of 11
(898 Views)

Hello lolo,

 

If you have downloaded the latest LabVIEW-Scilab Gateway installer (1.2), I believe the issue you are seeing is caused by a missing registry entry. Can you verify by letting me know if you have the following registry folder: "HKEY_LOCAL_MACHINE\SOFTWARE\National Instruments\LabVIEW\CurrentVersion"

 

If this folder is missing, we need to determine how that happened. Did you install a new version of LabVIEW and then uninstall a previous version?  If you're comfortable working in the Windows registry, a workaround to the problem is to create the CurrentVersion folder underneath the LabVIEW folder. In your 11.0 folder, note the contents of the Path, Version, and VersionString keys. Create identical keys in the CurrentVersion folder and the installer should behave normally.

 

If that registry folder is present, we need to do some additional investigative work to determine software versions and such on your system.

 

Grant M.
Senior Software Engineer | LabVIEW Tablets | National Instruments

0 Kudos
Message 9 of 11
(883 Views)

Thanks you very, very much !

The problem is solved by regedit-ing as you have said.

 

The moral is "un-install before installing new version".....

 

Thanks

 

0 Kudos
Message 10 of 11
(867 Views)