Showing results for 
Search instead for 
Did you mean: 

Initializing LUTs for FPGAs

Go to solution

I am currently trying to generate a waveform on an FPGA using a program to initialize a Look-up Table (LUT).  When I select Call Initialization VI, then select the path and hit OK, Labview begins to consume a bunch of CPU time but nothing seems to happen - none of the buttons function except the Open File dialog box and the close icon (red box with an x in the upper right hand corner) is greyed out.  Does anyone have any thoughts?  Maybe I am doing something wrong, but there is a dearth of documentation on this function.  I have attached the VI that I am using to try to initialize my table.


Any thoughts would be great.  


Cheers, Matt

Download All
0 Kudos
Message 1 of 10
0 Kudos
Message 2 of 10

Thanks for the reply, Huter.  I have already gone over this tutorial and I believe that I am following all the steps that are given in the example for generating the LUT.  I am outputting 40960 (the size of the largest memory block for the PXI-7841R) I16 elements (ranging from -32768 to 32767) into an array called Init Data Out (I have been unable to find documentation on this but both of the examples that I have been able to find indicate this is the name of the array from which the LUT will be populated).  I am given no indication that anything is wrong when I try to load the table, the controls just become unresponsive.  Can anyone tell me if I am doing something incorrectly?


The fact that the control becomes unresponsive without throwing an error also suggests that the functionality is not behaving as desired and should be corrected in future releases.  But, first I need to know what is happening.



0 Kudos
Message 3 of 10
I was able to get the same non-resposive dialog box behavior on my system using your code. I am not yet sure what the root of the problem is but I will work on it and let you know when I find out more.
0 Kudos
Message 4 of 10

Thanks, Hunter.  Some point soon, I will be getting directly in touch with the FPGA folks at NI.  I will let you know what I find out.


Cheers, m

0 Kudos
Message 5 of 10



While I was able to reproduce this hang with your code, I do not see the problem if I recreate the same code. It might be that this particular VI is corrupted. Do you see the pop up hang from any other VI's?


Let me know.

0 Kudos
Message 6 of 10



I haven't tried it with any other VIs run over that large of a set of numbers.  I will give that a go.  What do you mean by "corrupted"?  How did you recreate the same code?  I have used this VI previously to produce a signal on an AO 6733 and it worked just fine.  


Thanks, Matt

0 Kudos
Message 7 of 10

If I open the Configure Loop-Up Table 1D window and select define table»call Initialization VI and open one for the example LUT maker VI's it works fine for me. If we can get that one to work then we should be change it into your current VI piece by piece so we can find what about your VI might be causing this problem.


In any case I will file a CAR, because even with a "bad" initialization VI we would never expect the non responsive buttons. 

0 Kudos
Message 8 of 10
Accepted by cirrusio

This must have something to do with the complexity of the LUT initialization VI.  As a work around, I have simply written the data to a file which I then read for the LUT initialization.  I have attached the new VIs.


The lack of responsiveness is a problem as well as the lack of any indication of an error.

Download All
0 Kudos
Message 9 of 10

I filed a CAR (corrective Action Report) for this issue with LV R&D. This bug is only a problem with certain kinds of programiticly called VI's In your case the inverse FFT wich has a call library function node in it and casues the LUT Initilization dialog to hang. Another user came accross this bug when using mathscrip in the Initilization VI. You can use the CAR number below to track this issue to see when it will be fixed in futire version



This was reported to R&D (# 171812) for further investigation

Message 10 of 10