LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Image format for Stereo Vision.vi

Solved!
Go to solution

Hello!

 

I would like to try LabVIEW's built in example for Stereo Vision. As far as I tried about two days, I couldn't get the depth image from my pictures. I have tried many image formats and sizes, but none of them worked (the depth map was full black). Is there any trick with the NI pictures, or the example only works with them? Or I should change some parameters in the program? I would appreciate any help because I don't have any more idea why doesn't it work.

Thank you!

 

gbbalint

0 Kudos
Message 1 of 14
(2,343 Views)

Hello!

maybe all points in your depth image is bigger than the Maximum of the ZScale, then all point is black, so change the Maximum.

 

lizhuo_lin未命名.jpg

CLD
CAU
0 Kudos
Message 2 of 14
(2,323 Views)

Thank you!

 

I have tried it, but that wasn't the problem.  Don't you know where can I look after how to calibrate that example vi for my pictures?

0 Kudos
Message 3 of 14
(2,313 Views)

Hello! gbbalint

 

Can you upload your vi?  I use Stereo Vision Example.vi to calibrate my cameras.

I had calibrated my two cameras once after trying about one hundred times, I don`t know why I had succeed that time and now always fail.

Suggest to use the newest version of VDM, I update from VDM 2012 to VDM 2012 SP1, things get better, but problem goes on.

The most commen situation is like the following picture, the depth image is fragmented, and the rectified image is not good。

CLD
CAU
0 Kudos
Message 4 of 14
(2,306 Views)

foget the picture, bmp is not supported. 4.JPG

CLD
CAU
0 Kudos
Message 5 of 14
(2,305 Views)

Hello!

 

I use VDM 2012's Stereo Vision.vi but the Stereo Vision Example.vi for calibration doesnt even start for me, it needs a .lib file that I cant find on my computer :S

0 Kudos
Message 6 of 14
(2,300 Views)

Hello! gbbalint

I never encounter that problem. Which .lib does it need? Could you give me a screen shot? Do you install VAS? My VAS version is 2013.02.

CLD
CAU
0 Kudos
Message 7 of 14
(2,297 Views)

I have attached the two screenshots? So you say VAS 2013.02 may solve the problem?

Download All
0 Kudos
Message 8 of 14
(2,286 Views)
Solution
Accepted by topic author gbvbalint

Hello! gbbalint

 Your system is X64? Maybe you need not to install the newest VAS.

when the warning come out, click browse, then find NI_Vision_Acquisition_Software.lvlib in C:\Program Files(x86)\National Instruments\LabVIEW 2012\vi.lib\vision\driver,

Vision Acquisition CalculateFPS.vi is in Vision Acquisition Express Utility VIs.llb with same path.

CLD
CAU
Message 9 of 14
(2,282 Views)

Yes, it is x64. And Thank you! 🙂

0 Kudos
Message 10 of 14
(2,278 Views)