LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Icons in XY graph scale legend


@drjdpowell wrote:

Note: it seems by making an array of clusters containing a string and three buttons, you can paste in the entire Scale Legend structure at once.


I got some weird behavior when doing this.

 

LV did replace the array with my array, but the moving Booleans moved them out of the cluster.

 

LV crashed right after that. 

 

EDIT: Only when moving it by mouse. Even if you move them within the cluster, it's moved outside the cluster. Moving it by cursor works.

0 Kudos
Message 11 of 21
(106 Views)

I clicked Customise (right click) on the graph itself and then it opens the graph in the control editor. Within the control editor you can select the scale legend separately (i think in edit mode), then I clicked Edit -->> Customise Control again from the menu and this is what I get: Just the scale legend control without the X/Y and X.XX/Y/YY icons applied.

0 Kudos
Message 12 of 21
(100 Views)

@Arrowin wrote:

I clicked Customise (right click) on the graph itself and then it opens the graph in the control editor. Within the control editor you can select the scale legend separately (i think in edit mode), then I clicked Edit -->> Customise Control again from the menu and this is what I get: Just the scale legend control without the X/Y and X.XX/Y/YY icons applied.


You can customize the array element. Tried that before and failed, but I probably missed it.

 

It makes sense that the decals are not added, because the graph's routines are not active there.

 

I don't think it will do you much good, as the end result is the same as replacing the cluster or boolean. Once it's replaced in the graph's scale legend, the graph's routines become active again.

0 Kudos
Message 13 of 21
(91 Views)

@Arrowin wrote:

I clicked Customise (right click) on the graph itself and then it opens the graph in the control editor. Within the control editor you can select the scale legend separately (i think in edit mode), then I clicked Edit -->> Customise Control again from the menu and this is what I get: Just the scale legend control without the X/Y and X.XX/Y/YY icons applied.


I don't have that option; does anyone know why I wouldnt?

2021-04-08 11_55_36-Control 8 Control _.png

0 Kudos
Message 14 of 21
(84 Views)

@drjdpowell wrote:

@Arrowin wrote:

I clicked Customise (right click) on the graph itself and then it opens the graph in the control editor. Within the control editor you can select the scale legend separately (i think in edit mode), then I clicked Edit -->> Customise Control again from the menu and this is what I get: Just the scale legend control without the X/Y and X.XX/Y/YY icons applied.


I don't have that option; does anyone know why I wouldnt?

2021-04-08 11_55_36-Control 8 Control _.png


1) you have to click (select) the cluster (the array element, not the array)

2) use the Edit>Customize Control..., not the right click.

Message 15 of 21
(80 Views)

wiebe@CARYA wrote:

2) use the Edit>Customize Control..., not the right click.


That damn right-click menu, with its greyed out "Customize.." item, has been lying to me for years!  

0 Kudos
Message 16 of 21
(73 Views)

I just noticed when the boolean control has a width or height that is smaller than 14 pixels, the X/Y icon will not be drawn on top of the button. So it is of course possible to change the button by a customised one but you'll have to make sure the size doesn't exceed 14 pixels in both height AND width. If it is bigger, then the routine kicks in and draws the icons on top of them.

For the X.XX/Y.YY icon, the size is a different up to 18 pixels in width and 13 pixels in height, so go below that in either width or height and the icon will not be drawn for the second boolean.

0 Kudos
Message 17 of 21
(64 Views)

wiebe@CARYA wrote:

@drjdpowell wrote:

Note: it seems by making an array of clusters containing a string and three buttons, you can paste in the entire Scale Legend structure at once.


I got some weird behavior when doing this.

 

LV did replace the array with my array, but the moving Booleans moved them out of the cluster.

 

LV crashed right after that. 

 

EDIT: Only when moving it by mouse. Even if you move them within the cluster, it's moved outside the cluster. Moving it by cursor works.


Yeah, this is seems to be a special cluster in a special array, that prevents removing the controls.  Swapping out either Cluster or Array means this crash can happen. 

0 Kudos
Message 18 of 21
(53 Views)

I went into this and tried a few things. I did find a way to do what you are looking to do. Fist open the control in advanced --> Customize. Click on the control then go to the edit menu item and select:

 

aeastet_0-1617898183090.png

 

This will bring up the The graph control in a different window. It should look like this:

aeastet_1-1617898470457.png

Now click on the button you want to change and do the same thing you did above:

aeastet_2-1617898535042.png

It should look like this:

aeastet_3-1617898600785.png

Now you can replace the pictures that are default with the ones that you want to use:

 

Like this:

aeastet_4-1617898664255.png

Use the import from file options. Switch to the other image and replace it again. Now save and replace and you have your custom control.

Tim
GHSP
0 Kudos
Message 19 of 21
(34 Views)

I was able to get this to work:

aeastet_0-1617899064176.png

 

Tim
GHSP
0 Kudos
Message 20 of 21
(32 Views)