LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Icon editor - no glyphs

Hi, I'm using LabView 2009 and have an issue with the Icon Editor - no glyphs are listed.  I've tried syncing with NI.com icon library and that still won't work.

 

I found this thread: http://decibel.ni.com/content/thread/8011?tstart=0 and applied the fix near the end of the thread to GET HTTP.vi.  That fixed my original downloading problem (Error 42) but now I run into Error 7.  The dialog box says this: Error 7 occurred at File/Directory Info in Check Path.vi->Read PNG File.vi->ni.com_iconlibrary.vi

 

I found instructions to update the icon library manually (http://zone.ni.com/reference/en-XX/help/371361F-01/lvhowto/synchronizing_icon_library/), however the option to manually sync never comes up as the dialog box just closes and reverts me back to the Icon Editor.

 

Any ideas on how to fix this?

 

Thanks!

0 Kudos
Message 1 of 10
(2,403 Views)

You are probably not using the same login as LV was installed with.  The Glyphs are in your ../my documents/labview data folder

Jim

LV 2013
0 Kudos
Message 2 of 10
(2,390 Views)

I'm definitely using the same Windows (7) account if that's what you mean.  The only file in my Documents\LabView Data\Glyphs folder is Glyphs.9.0.1.bin and it's only 4 bytes in size.

 

0 Kudos
Message 3 of 10
(2,385 Views)

Bump for any ideas?  I've tried disconnecting from my network to force the manual dialog.  I downloaded the zip and xml files, and pointed the manual dialog to these files.  I got no errors, but still nothing shows up in my list of glyphs or templates.  Help?

0 Kudos
Message 4 of 10
(2,326 Views)

Is your LabVIEW data folder set to read-only?

C:\Documents and Settings\<USERNAME>\\My Documents\LabVIEW Data\

The icon editor tries to create two folders:

..\LabVIEW Data\Glyphs

..\LabVIEW Data\Icon Templates

 

If none of those folders exist and/or it is not possible to get access to the LabVIEW Data folder the icon editor won't be able to show any glyphs/templates.

Attached pls find my version of the LabVIEW Data\Glyphs folder.

 

 

http://www.newgistics.com
Message 5 of 10
(2,320 Views)

Thanks, ThSa. 

 

I think my LabView Data folder was partially set to read-only.  However I can't seem to set all the contents to not be read-only - Windows shows the read-only checkbox as filled (rather than a checkmark) meaning that some contents are read-only, some are not.  No matter what I do the checkbox remains filled instead of cleared when I try to make everything not read-only.  Regardless, trying to sync with ni.com resulted in another failure afterwards.

 

Putting the contents of your zip file into my Glyphs folder worked.  Are there Icon Templates included with LabView as well?  Is it possible to get these as a zipped folder?

 

Thanks again!

0 Kudos
Message 6 of 10
(2,311 Views)

Sure thing.

 

Attached pls find the Icon Templates.zip file.

If you find out what the reason was that it didn't work, pls let me know.

 

Thanks!

 

 

http://www.newgistics.com
Message 7 of 10
(2,299 Views)

Thanks again for the upload.  I haven't figured out what caused this in the first place, but your files gave me the end result I was looking for.

 

0 Kudos
Message 8 of 10
(2,292 Views)

Maybe this changed in a later version, but now in the Icon Editor there is a "Refresh templates from disk" button in the upper right corner of the area where the icons are displayed.  Press that button and any templates in the default directory will be displayed.

0 Kudos
Message 9 of 10
(1,172 Views)

I was having this issue as well and found a solution that worked for me.  My Default Data Directory was located in a location that didn't actually exist (still not sure how that happend).  By going to Options=>Paths=>Default Data Directory and pointed it to a new location.  After "replacing" the directory I did a rebuild on LabVIEW and all the glyphs got added to the new LabVIEW Data folder.  Hope this helps!

0 Kudos
Message 10 of 10
(1,146 Views)