Showing results for 
Search instead for 
Did you mean: 

IVI driver not working with my DPO4054B scope

So I got two new DPO4054B scopes.  I have tried both IVI drivers from Tektronix and NI's websites.  They are:


NI -> tkdpo4k_setup.exe

Tektronixs ->Tkdpo2k3k4kIVIDriver1.3.exe


Both have issue.  I started with the textronixs one and the issue it has is the "IVIscope configure edge trigger source" function is not working.  It doesn't return any errors, just doesn't do anything.  I have called the configure type and input type as it requires prior, setting it to "edge trigger" and "DC".  There are some other oddities with this driver, but in all it seems to work.  I did note that in NI MAX there is an initialization string to declare the model.  I have tried DPO4054 and DPO4054B, niether seems to have any affect.  Even the default DPO2023 works the same.


The NI driver works perfectly when it initializes.  Unfortunately, 90% of the time, it times out on the initialize function.  I do not understand what I could be doing wrong as the only real input to this is the logical name which I know is correct.


Any thoughts?  I have NI VISA 5.4 and IPC4.6 installed.  Running Labview 2013.  I noted there is a version 14???? of both now available.  Was thinking of trying those.


0 Kudos
Message 1 of 4
The initialize function certainly has more than the logical name passed to it. Have you used NI'S I/O Trace to see what query is timing out? What is the physical connection?

What about the LabVIEW driver? What is the purpose of using IVI if you're not using the class driver?
0 Kudos
Message 2 of 4

The initialize function has logical name, and whether to query and reset the device.  I currently have these set to no, but have tried yes as well with no affect.  I am not familar with the IO trace feature.  I will look into that.  Not sure I understand the question about class specific.  If I am using the IVI drivers, I don't want to use the class specific, that would defeat the point.  I am only using the IVIscope functions so I can swap in different scopes.


The hardware is the computer has a USB to GPIB adapter.  The DPO4054B has the TEK-USB-488 adapter so it all works via GPIB.

0 Kudos
Message 3 of 4
In order to swap instruments, you do have to use the class driver which it seems that you are using and what I missed. Sorry for the confusion.

I'm not familiar with a gpib controller from tek. Perhaps that is the issue. How does it appear in MAX and are you able to run queries from there?
0 Kudos
Message 4 of 4