Showing results for 
Search instead for 
Did you mean: 

IMAQ image works in VI but not in exe

Hello everyone!


I am using LV 17.0.1 32 bit.

I made a VI where I am showing image from the 2D array of values which works OK in the VI.

But when I make an executable file, the image is black and IMAQ part of the program is not responding. I can not zoom or change other properties of the image.

The rest of the program works normally and behaves as there would be no IMAQ in the code.

This happens on the same PC as I am running the VI and also on other computers where the program was installed with installer (including LV and IMAQ runtimes).

IMAQ function generates no error code.

I remember from the past, it was working without any spacial problems



Additionally: For other PC's, do I need IMAQ license for using just IMAQ array to image function?


Thank You in advance.

Kind regards,







0 Kudos
Message 1 of 6

I have had this before. I am pretty sure I got around it by installing the vision module run time installer even though i don't think it should be necessary.


It can be downloaded here 


I think there are some resources missing as part of the standard LabVIEW install when running vision stuff in runtime...even if you are using stuff which doesn't need the separate vision runtime license.


This was a while ago so I might have misremembered 

0 Kudos
Message 2 of 6



     If you attach your VI (with all the other files that it needs to run, not counting the ones that are part of LabVIEW), we can "try it ourselves" and if it fails for us, figure out "what's missing" (or "what's wrong") and make "informed" suggestions.  Or we could just guess ...


     If this is part of a LabVIEW Project, compress the folder containing the Project file (.lvprog) and all the VIs and attach the resulting .zip files.  We'll take a look ...


Bob Schor


P.S. -- if you need it to work with a particular Image File, be sure to also include the Image file.

0 Kudos
Message 3 of 6



Since my project is rather complicated I prepared a small test project which behaves the same. VI is ok, but when I make .exe IMAQ is not responsive and the rest works OK.

I attached everything in zip.


Thank You for your effort.


Kind regards,


0 Kudos
Message 4 of 6

I repaired the project so it now contains a VI.

Also i discovered that in LV 2020 the dependencies folder is created automatically in the project and when compiled to .exe it works as it should.

But in LV 2017 and 2018 no such folder is created.

I guess here is the catch.

Now I wonder, how to add such dependencies in LV2017 project as I do not want to migrate my whole system to LV2020.


Kind regards,






Download All
0 Kudos
Message 5 of 6



     Thank you for attaching your Project.  When I opened it, the Project file, including the Build Specifications, was empty.  I added IMAQ testVI to the Project, and created a Build Specification to create an Application (.exe).


     When I ran the VI from within LabVIEW, I could see you were generating a ramp and creating an Image that matched the Gray Scale value of the Ramp.  When I ran the executable I built from this VI, it did exactly the same thing (as it should).


     I was running this on LabVIEW 2019 SP1, which is what is installed on this computer.  I am quite confident that it will work identically on a LabVIEW 2017 system (I do have one such system available, but it's a little difficult to get to right now).


     Did you mean to create an "empty Project"?  Do you know that in order to build an Executable, you must do it from VIs that are include in the Project?  Could this be your problem?


Bob Schor

0 Kudos
Message 6 of 6