LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

IMAQ extract (-1074396077), Crop Image

Solved!
Go to solution

Hi,

 

I have a 12 bit CCD camera (Vosskühler). I use the IMAQ vi's, to take the image from the CCD cam the IMAQ Snap.vi. The communication to the camera works fine...

 

I'd like to crop the "full" image, take a rectangular region of interest of this image. For this purpose I use the IMAQ Extract.vi.

 

Problem: when I try to crop directly the image which is coming from the camera, the IMAQ Extract.vi generates an error (-1074396077). BUT when I first save the picture on a local drive, reload it again and try to crop it then, then it works properly ! What can be the problem ?

 

I attached the vi which does not work...

 

Many thanks for your help

 

PS: I mean I have a solution with the save, close and reload, but I don't like this !

 

Cheers, Matthias

0 Kudos
Message 1 of 8
(4,798 Views)

Hello MJ77,

 

can you please delete the image type of the croped image, so no constant is connected?

 

test.PNG

best regards
Alexander
0 Kudos
Message 2 of 8
(4,750 Views)

Hi Alexander,

 

unfortunately it also does not work ! I have deleted the constant (grayscale u16) from the croped image, but the error still occur.

 

In my understanding, the "depth" of the pixel (grayscale u8, u16, ...) should not affect a cropping function, but probably I'm wrong.

 

Do you have another idea ?

 

Best regards, Matthias

0 Kudos
Message 3 of 8
(4,736 Views)

What happens if you don't wire "Image Dst" into the IMAQ Extract VI?

0 Kudos
Message 4 of 8
(4,726 Views)

Hi,

 

if I don't wire the "Image Name" input of the "IMAQ Extract.VI" then the LabVIEW can't be executed...

if I wire "Image Dst" to the "Image Name" input --> same error...

 

Did I understand your answer right ?

 

Other ideas ?

 

Many thanks. Matthias

0 Kudos
Message 5 of 8
(4,719 Views)

Remove the two IMAQ Dispose functions -- they are destroying your images (which are being built just fine, I checked) before you can see them, then when you try to manipulate non-existant images, you get an error.

 

Bob Schor

0 Kudos
Message 6 of 8
(4,709 Views)
Solution
Accepted by topic author MJ77

Hello MJ77

 

attached a vi in this you can see what image type came out of the snap function and also the option to load from a file.

I get the same error like you if the image types are not the same.

best regards
Alexander
0 Kudos
Message 7 of 8
(4,684 Views)

Thanks at all !

 

The problem was the data type. Although I defined U16, it was I16 returned from the camera.

 

LG Matthias

0 Kudos
Message 8 of 8
(4,648 Views)