LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

IMAQ Vision AVI create - file access denied error

Hello:

I am getting some really strange behavior with the IMAQ Vision AVI create function.  I am seeing the following error with the following file name or pretty much any other file name I try.  I did try to hard code the same file path name, and one time it worked, but another time it did not.  Anyone seen this error before?



I will cross-post in the Vision forum also.

Thanks,

Don


Message Edited by DonRoth on 07-28-2008 11:27 AM
0 Kudos
Message 1 of 9
(4,371 Views)

Your file may still be in memory, so you cannot over-write it.

I will venture to guess that whatever name yo give, it may work the first time you give it a new name, but not on subsequent tries.  Unless you close Lavbiew, re-start Labview and then you can save the same name again.  Is this an accurate description? 

If not....  Are you closing the file refernece after you are done with it?  Do you set any write protection attributes to the file?   Can you post an image of how to create / write / close the file (maybe easier to post the code)?

R

______________________________________________________________________
0 Kudos
Message 2 of 9
(4,360 Views)
Here is the simple version of the code.  I have even gotten out of LabVIEW and then come back in and still could not save to AVI (even if deleting the old file of same name) so not sure what is going on. The error occurs right on the error output of Create AVI.vi...Don




Message Edited by DonRoth on 07-28-2008 01:33 PM
0 Kudos
Message 3 of 9
(4,342 Views)
ps. Note that I am just using a simple gray scale color table here but in the real code I feed in the actual color table associated with the image garnered from the color table property node.  The stuff inside the 'for loop' is not something you need to worry about as the error occurs at the output of the 'Create AVI' fx to the left of the 'for loop'.
0 Kudos
Message 4 of 9
(4,319 Views)
Thanks to Eric Reid at NI, this problem has been solved.  One has to close access to the file prior to generating the new reference for the AVI file.



Thanks again to Eric.


Message Edited by DonRoth on 07-31-2008 08:15 AM
Message 5 of 9
(4,281 Views)

I cannot acccess the image form vision acquisiton express vi so can anyone help me with this......

But I can acces the image stored default location in vision.What is the reason for it? There is an error in ssim what is it?

0 Kudos
Message 6 of 9
(1,160 Views)

Raja,

 

Is this a large or complex VI? Whenever I try to open it, it causes LabVIEW to hang. Could you post screenshots of the code you're using and the way you have the express VI configured?

 

Also, you may have better luck posting your own new thread, as this one is from 2008. Posting a new thread will make it more likely that your question will be noticed.

0 Kudos
Message 7 of 9
(1,142 Views)

Yes its somewhat complex VI involving SSIM vi (structural similarity) inside the program.This program involves finding difference between two images.The invalid image type which I have encountered has been rectified.Thank you for your reply sir.

Can you help me with identifying dust in an image and extracting  its real world coordinates using labview..? and moving a stepper motor by myrio programming...?

0 Kudos
Message 8 of 9
(1,137 Views)

For the first of these, please look at the "Particle Filter" vision example.

 

For the latter, it largely depends on what toolkits and modules you have available for motion control, and what motor and drive you're using. I recommend you post in the motion control forums:

 

Motion Control and Motor Drives
https://forums.ni.com/t5/Motion-Control-and-Motor-Drives/bd-p/240

0 Kudos
Message 9 of 9
(1,123 Views)