LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

(IEFSR 12) Flexiforce sensor

Highlighted

Hi guy,

 

I'm trying to read an accurate data from Flexiforce sensor throughout Arduino and LabView.

the idea is, I can't see the measurment on th metering more than a blink. 

you can check the design. However, I'm not that strong in Labview.

 

any idea will help. 

 

 

Thanks 

 

 

0 Kudos
Message 1 of 3
(1,030 Views)

Hello,

I’ve looked into the issue and it seems like there could be a few possibilities as to why you’re getting only one reading.

 

1. Labview and the Arduino can’t maintain communication due to incorrect baud rate. You can remedy this by using the Visa Configure Serial Port function (Functions Palette -> Instrument I/O -> Serial), instead of the Visa Open function, to set the baud rate as well as other parameters.

2.There is nothing to read on the port. You can try using the Find First Error function (Functions Palette -> Dialog & User Interface), to check if there is anything to read at the desired port.

3. The Arduino bootloader is not allowing synchronization between the Arduino and your program. The Arduino bootloader can last between 8-10 second, hence you could use an initial While loop to wait 10 seconds before you start acquiring data.

 

Hopefully these solutions should help, but there is also a forum post which seems to be similar to your own. Here is the link: https://forums.ni.com/t5/LabVIEW/How-to-read-Serial-Data-from-Arduino-using-labview-VISA/td-p/149786....

For future reference please consult the forums first, as there is a wealth of knowledge already there which should be able to help.

Thank you
Ed

0 Kudos
Message 2 of 3
(942 Views)

Hi Ed, 

 

thank for the reply, I already found the problem. it was with the delay time, wasn't matching. 

 

but thanks anyway. 

 

 

 

Regards,

Najeeb

0 Kudos
Message 3 of 3
(940 Views)