Showing results for 
Search instead for 
Did you mean: 

I'm stuck... Installation of LabVIEW 2019 has screwed up network settings on two different PCs now...

Go to solution

Hi forums,


Just putting this issue out there on the off chance someone else has experienced the same issue.

Installation of LabVIEW 2019/LabVIEW 2019 RTE has rendered two of my systems unusable now as I cannot connect to network TCP resources, network shares, or IP cameras using IMAQdx from either PC. I can't even communicate via TCP between LabVIEW scripts running on the same PC (localhost).

This issue has reappeared twice now under slightly different circumstances.

  1. It happened on PC1 after installing an executable built using LabVIEW 2019, the LabVIEW 2019 development environment was not installed on this PC.
  2. It happened on PC2 (my main PC) after installing the LabVIEW 2019 development environment.

In both cases I can't connect to my IP cameras. In the second case MAX reports "There was a problem updating the settings for this device. The operation timed out." In both cases I can ping the devices and view their web interfaces but they're not showing up in MAX.

In the first case I completely uninstalled the application and LabVIEW 2019 RTE along with all NI components (on the advice of NI AE), then reinstalled LabVIEW 2018, then wiped again and downgraded to LabVIEW 2010, but the problem persists. I have been fighting this issue for over a week now, and now it appears to have happened to a second PC.

I'm currently running a repair on the second system but I don't have much faith that it will fix the problem.

I've also tried checking some of the background services that are running (NI System Web Server) tried restarting and rebooting but no luck. Are there any other services I should check are running?


Has anyone else had this issue with an upgrade? I feel like I've exhausted all of my avenues.





0 Kudos
Message 1 of 6

After searching for the MAX message I came across this forum post and after repairing DAQmx my second system can now connect to IP cameras and TCP resources.

Repair of DAQmx also repairs the NI System Web Server so I am guessing this was root of the problem. Fingers crossed this works on my other system now.

0 Kudos
Message 2 of 6


     I've been using (and installing) LabVIEW since 7.0 (others on the Forum have much more experience than I do).  LabVIEW 2019 is, by far, the most troublesome and difficult Version I have ever encountered.  The Good News is that the most recent versions of NIPM (19.5 and 19.6) have made this a little less painful.


My advice is to do a complete uninstall of all NI software, then start the re-install.  Install "slowly" -- resist the temptation to specify everything at the beginning and trusting NIPM to do it right.  Install only LabVIEW (nothing else) first, then toolkits/modules one at a time (rebooting frequently), and Drivers last.  Don't install anything you don't need.  Check the NI Services after every step -- you should start with at least a dozen, and once in, they should "stay put".


Bob Schor

Message 3 of 6

Ok so a repair on the second (more fragile) PC didn't work. I'm going to follow your advice Bob and uninstall everything, then reinstall bit-by-bit. On the last reinstall I specified everything at the beginning so maybe that was the problem - fingers crossed this fixes it

0 Kudos
Message 4 of 6
Accepted by topic author AudioVideoDisco

Posting my solution in the hopes that it saves someone else some valuable troubleshooting time:


I ended up completely wiping the system (which was Windows 7) and reinstalling/upgrading to Windows 10. Then reinstalling LabVIEW 2018 (I'm not going near LabVIEW 2019 again).

System now works with LabVIEW 2018.


Thanks Bob for your help, I found out the hard way to always remain at least one version below the latest LabVIEW release.

0 Kudos
Message 5 of 6

LV2019 does not play well with other versions of LabVIEW no matter how or in what order you install them.


Just don't install anything other than LV2019. We found similar issues with LV2019 and Ethernet connection issues with cRIO and Remote systems in MAX.


We discovered, that the cRIO Discovery service in MAX was turn OFF and the service was set to MANUAL. It should be ON and set to AUTOMATIC.


MAX error handling does not seem to check or report that some of the NI services MAX relies on are OFF and no longer set to Automatic [start].


Open Windows Services, scroll down the alphabet list till you get to "NI...." Anything turned OFF, turn ON. Especially discovery services.


LV2019 install is a mess.


0 Kudos
Message 6 of 6